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UNIT – I 

BASIC OF COMPUTER SYSTEM 

 

 

 

UNIT 1 -    BASIC OF COMPUTER SYSTEM 

Memory unit– CPU-Input Devices: Key board, Mouse and Scanner. Output 

devices: Monitor, Printer. Introduction to Operating systems & its features: 

DOS– UNIX–Windows. Introduction to Programming Languages. 
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UNIT OBJECTIVES 

 This unit aims to provide a comprehensive understanding of the various input 

and output (I/O) devices integral to a computer system.  

 Learners will explore different input units, and output units 

 Learners will have a thorough knowledge of the functionalities and types of 

these devices, enabling them to appreciate their roles in enhancing computer 

system interactions and performance. 

 It explores the distinctions and purposes of system software, such as operating 

systems and utility programs, alongside programming languages. 
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1.1 MEMORY UNIT 

1.1.1 Primary Storage 

RAM (Random Access Memory) 

 The primary storage is referred to as Random Access Memory (RAM) because it is 

possible to randomly select and use any location of the memory directly to store and 

retrieve data. 

 It takes same time to any address of the memory as the first address It is also called 

read/write memory. 

 The storage of data and instructions inside the primary storage is temporary. It 

disappears from RAM as soon as the power to the computer is switched off. 

 The memories, which lose their content on failure of power supply, are known as volatile 

memories. So now we can say that RAM is volatile memory. 

A RAM constitutes the internal memory of the CPU for storing data, program and program 

result. It is read/write memory. It is called random access memory (RAM). Since access 

time in RAM is independent of the address to the word that is, each storage location 

inside the memory is as easy to reach as other location & takes the same amount of time. 

It can reach into the memory at random & extremely fast but can also be quite expensive. 

RAM is volatile, i.e. data stored in it is lost when we switch off the computer or if there is a 

power failure. Hence a backup uninterruptible power system (UPS) is often used with 

computers. RAM is small both in terms of its physical size and in the amount of data it can 

hold. 
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Static RAM (SRAM) 

The word static indicates that the memory retains its contents as long as power 

remains applied. However, data is lost when the power gets down due to volatile nature. 

SRAM chips use a matrix of 6-transistors and no capacitors. Static RAM is used as cache 

memory needs to be very fast and small. 

Dynamic RAM (DRAM) 

DRAM, unlike SRAM, must be continually refreshed in order for it to maintain the 

data. This is done by placing the memory on a refresh circuit that rewrites the data several 

hundred times per second. DRAM is used for most system memory because it is cheap 

and small. All DRAMs are made up of memory cells.  

ROM (Read Only Memory) 

There is another memory in computer, which is called Read Only Memory (ROM). Again it 

is the ICs inside the PC that form the ROM. The storage of program and data in the ROM 

is permanent. The ROM stores some standard processing programs supplied by the 

manufacturers to operate the personal computer. The ROM can only be read by the CPU 

but it cannot be changed. The basic input/output program is stored in the ROM that 

examines and initializes various equipment attached to the PC when the switch is turned 

ON. The memories, which do not loose their content on failure of power supply, are known 

as non-volatile memories. ROM is non-volatile memory. ROM stands for Read-Only 

Memory. It is a non-volatile memory that is used to stores important information which is 

used to operate the system. 

PROM (Programmable read-only memory) 

PROM is a form of digital memory. In this type of ROM, each bit is locked by a fuse 

or anti-fuse. The data stored in it are permanently stored and cannot be changed or 

erasable. It is used in low-level programs such as firmware or microcode. 

EPROM (Erasable programmable read-only memory) 

EPROM also called EROM, is a type of PROM but it can be reprogrammed. The 

data stored in EPROM can be erased and reprogrammed again by ultraviolet light. 

Reprogrammed of it is limited. Before the era of EEPROM and flash memory, EPROM 

was used in microcontrollers. 
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EEPROM (Electrically erasable programmable read-only memory) 

EEPROM (also E2PROM) stands for Electrically Erasable Programmable Read-

Only Memory and is a type of non-volatile memory used in computers, integrated in 

microcontrollers for smart cards and remote keyless system, and other electronic devices to 

store relatively small amounts of data but allowing individual bytes to be erased and 

reprogrammed. 

Let’s Sum Up 

RAM (Random Access Memory) and ROM (Read-Only Memory) are essential types 

of primary storage in computers. RAM provides fast, temporary storage for data and 

program instructions during operation, while ROM retains crucial firmware and instructions 

that remain intact even when the computer is powered off, ensuring essential functions like 

booting up and system initialization. 

1.1.2 Secondary Storage 

Magnetic Tapes 

Magnetic tape is a type of secondary storage medium that uses a thin, magnetically 

coated ribbon of plastic to store digital data. It is one of the oldest forms of data storage 

and has been used for decades in various industries for its reliability, durability, and cost-

effectiveness. Despite advancements in storage technology, magnetic tapes continue to 

be used today, particularly for long-term archival and backup purposes. 
 

Magnetic Disk 

A magnetic disk is a type of secondary storage device that uses magnetic storage 

to store and retrieve digital data. It consists of one or more thin circular disks coated with a 

magnetic material, typically iron oxide. Magnetic disks are a fundamental component of 

many computer systems and are used for both internal and external storage purposes 

Hard Disk  

Hard Disk is a storage device (HDD) that stores and retrieves data using magnetic 

storage. It is a non-volatile storage device that can be modified or deleted n number of 

times without any problem. Most computers and laptops have HDDs as their secondary 

storage device. It is actually a set of stacked disks, just like phonograph records. In every 

hard disk, the data is recorded electromagnetically in concentric circles or we can say 

track present on the hard disk, and with the help of a head just like a phonograph arm(but 

https://www.geeksforgeeks.org/hdd-full-form/
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fixed in a position) to read the information present on the track. The read-write speed of 

HDDs is not so fast but decent. It ranges from a few GBs to a few and more TB. 
 

Floppy Disks 

Floppy Disk is also known as a floppy diskette. It is generally used on a personal 

computer to store data externally. A Floppy disk is made up of a plastic cartridge and 

secured with a protective case. Nowadays floppy disk is replaced by new and effective 

storage devices like USB, etc. 

Optical disks 

Optical disks are storage media that use optical technology to read and write data. 

They consist of a flat, circular disc made of a polycarbonate substrate coated with a 

reflective layer and protected by a clear plastic cover. Optical discs store data as 

microscopic pits and lands on the surface of the disc, which are read by a laser beam. 

Compact Disks 

 CD: It is known as Compact Disc. It contains tracks and sectors on its surface to 

store data. It is made up of polycarbonate plastic and is circular in shape. CD can 

store data up to 700MB. It is of two types. 

 CD-R: It stands for Compact Disc read-only. In this type of CD, once the data 

is written can not be erased. It is read-only. 

 CD-RW: It stands for Compact Disc Read Write. In this type of CD, you can 

easily write or erase data multiple times. 

 DVD: It is known as Digital Versatile Disc. DVDs are circular flat optical discs 

used to store data. It comes in two different sizes one is 4.7GB single-layer discs 

and another one is 8.5GB double-layer discs. DVDs look like CDs but the 

storage capacity of DVDs is more than as compared to CDs. It is of two types: 

Flash Drives 

Flash drives, also known as thumb drives, pen drives, or memory sticks, are 

portable data storage devices that use flash memory for data storage. They were 

introduced in the late 1990s and quickly became one of the most popular forms of 

removable storage. USB flash drives are available in a wide range of capacities, from a 

few megabytes to multiple terabytes. Common capacities include 4 GB, 8 GB, 16 GB, 32 

GB, 64 GB, and 128 GB. 

https://www.geeksforgeeks.org/what-is-a-cd-compact-disk/
https://www.geeksforgeeks.org/dvd-full-form/
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Comparison Summary 

Feature Primary Storage Secondary Storage 

Volatility Volatile (data lost when power 

off) 

Non-volatile (data retained when power 

off) 

Speed Very fast Slower 

Capacity Limited (GB range) Large (TB or PB range) 

Examples RAM, Cache HDDs, SSDs, Optical Discs, External 

Drives 

Use Cases Active processes, running 

applications 

Long-term data storage, backups, data 

transfer 

 

 

Let’s Sum Up 

Secondary storage devices like floppy disks, SSDs, hard disks, and magnetic disks 

play crucial roles in storing and retrieving data in computers. They vary in capacity, speed, 

and durability, offering diverse options to meet the needs of different computing tasks, 

from archival storage to high-speed data access in modern computing environments. 

Check your Progress 

1. Which of the following is an example of primary storage? 

A) Hard Disk Drive (HDD) 

B) Random Access Memory (RAM) 

C) Solid State Drive (SSD) 

D) USB Flash Drive 

Answer: B) Random Access Memory (RAM) 

2. Which type of primary storage is commonly used to store the BIOS firmware? 

A) RAM 

B) Cache Memory 

C) ROM 

D) Virtual Memory 

Answer: C) ROM 
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3. Which of the following is considered as primary storage? 

A) Hard disk 

B) RAM 

C) CD-ROM 

D) DVD 

Answer: B) RAM 

4. What is the main purpose of secondary storage? 

A) To provide temporary data storage 

B) To store data permanently 

C) To perform calculations 

D) To execute programs 

Answer: B) To store data permanently 

5. Which of the following devices is an example of secondary storage? 

A) Cache memory 

B) USB flash drive 

C) Processor registers 

D) Video RAM 

Answer: B) USB flash drive 

 

1.2 CPU 

 

A block diagram of a computer typically outlines the major components and their 

interconnections. Here's a basic block diagram illustrating the key components of a 

computer system: 



CDOE - ODL B.SC (COMPUTER SCIENCE) – SEMESTER IV UNIT - I 

 

9 Periyar University – CDOE| Self-Learning Material 

 

 

Input Devices: Devices such as keyboard, mouse, touchpad, or touch screen that allow 

users to interact with the computer system by providing input. 

Central Processing Unit (CPU): The brain of the computer, responsible for executing 

instructions, performing calculations, and controlling the overall operation of the system. 

Memory (RAM): Temporary storage that holds data and instructions that the CPU needs 

to access quickly. Random Access Memory (RAM) allows for fast read and write 

operations but is volatile (loses data when power is off). 

Arithmetic Logic Unit (ALU): The part of the CPU that performs arithmetic and logical 

operations, such as addition, subtraction, AND, OR, etc. 

Control Unit: Manages the execution of instructions, fetches instructions from memory, 

decodes them, and coordinates the operation of the other CPU components. 

Cache Memory: High-speed memory located within or close to the CPU that stores 

frequently accessed data and instructions, speeding up access times. 

Storage Devices: Devices such as Hard Disk Drives (HDDs), Solid State Drives (SSDs), 

or Flash drives used for long-term storage of data and programs. 

 

Let’s Sum Up 

The CPU, or Central Processing Unit, is the brain of a computer, responsible for 

executing instructions and processing data. It consists of arithmetic and logic units that 
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handle calculations and decision-making, crucially determining the speed and efficiency of 

a computer's operations.  

 

1.3 INPUT UNITS: KEYBOARD 

Keyboard is the most common and very popular input device which helps to input 

data to the computer. The layout of the keyboard is like that of traditional typewriter, 

although there are some additional keys provided for performing additional functions. 

 

 

Keyboard 

Keyboards are of two sizes 84 keys or 101/102 keys, but now keyboards with 104 keys or 

108 keys are also available for Windows and Internet. 

Key Types Description 

Typing Keys These keys include the letter keys (A-Z) and digit keys (09) 

which generally give the same layout as that of typewriters. 

Numeric Keypad It is used to enter the numeric data or cursor movement. 

Generally, it consists of a set of 17 keys that are laid out in 

the same configuration used by most adding machines and 

calculators. 

Function Keys The twelve function keys are present on the keyboard 

which is arranged in a row at the top of the keyboard. Each 

function key has a unique meaning and is used for some 

specific purpose. 

Control keys These keys provide cursor and screen control. It includes 

four directional arrow keys. Control keys also include 

Home, End, Insert, Delete, Page Up, Page Down, 

Control(Ctrl), Alternate(Alt), Escape(Esc). 
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Special Purpose Keys Keyboard also contains some special purpose keys such 

as Enter, Shift, Caps Lock, Num Lock, Space bar, Tab, 

and Print Screen. 

 

1.4 MOUSE 

Mouse is the most popular pointing device. It is a very famous cursor-control device 

having a small palm size box with a round ball at its base, which senses the movement of 

the mouse and sends corresponding signals to the CPU when the mouse buttons are 

pressed. 

 

 

 

 

 

 

Generally, it has two buttons called the left and the right button and a wheel is present 

between the buttons. A mouse can be used to control the position of the cursor on the 

screen, but it cannot be used to enter text into the computer. Most mice are now optical 

which means they use a laser to detect and track movement across the surface. Mice can 

be wired or wireless.  

 

Mouse operations  

 Click: pressing and releasing a button.  

 (left) Single-click: clicking the main button.  

 (left) Double-click: clicking the button two times in quick succession counts as a 

different gesture than two separate single clicks.  

 (left) Triple-click: clicking the button three times in quick succession counts as a 

different gesture than three separate single clicks. Triple clicks are far less common 

in traditional navigation.  
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 Right-click: clicking the secondary button, or clicking with two fingers. (This brings a 

menu with different options depending on the software)  

 Middle-click: clicking the tertiary button.  

 Drag and drop: pressing and holding a button, then moving the mouse without 

releasing.  

 

1.5 SCANNERS AND ITS TYPES 

A scanner is an input device that scans documents such as photographs and pages 

of text. When a document is scanned, it is converted into a digital format. This creates an 

electronic version of the document that can be viewed and edited on a computer. 

Most scanners are flatbed devices, which mean they have a flat scanning surface. This is 

ideal for photographs, magazines, and various documents. Most flatbed scanners have a 

cover that lifts up so that books and other bulky objects can also be scanned. Another type 

of scanner is a sheet-fed scanner, which can only accept paper documents. While sheet-

fed scanners cannot scan books, some models include an automatic document feeder, or 

ADF, which allows multiple pages to be scanned in sequence.  

 

Types of Computer Scanners  

 Sheet fed scanner - scans paper by feeding it into the scanner  

 Handheld scanner - scans text and images by dragging the device over 

the page you want to scan  

 Card scanner - designed to scan business cards  

 

Prominent features of a scanner include: 

Reliability - Unlike certain forms of data transmission, scanning involves only transfer of 

hard images to digital forms. The role of the end-user is limited in case of 

scanning. And as they are not dependent on two-way communication, they 

can also help in storing important information or transmitting important 

information. 

Efficiency - Modern scanners are built for efficiency and speed. And it comes with ease 

of use as well as convenience. 
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Quality -  Scanning ensures the best resolution possible for digital images. Compared 

to fax machines, which may find it difficult to reproduce the accurate details, 

scanners can reproduce images with high resolution and precisions. They 

are quite useful for photography and engineering arenas. 

Cost saving-One of the biggest advantage of scanning is the replacement of physical 

files/forms with digital ones. Along with saving physical space, which has to 

be used for storage, there are also environmental benefits by using scanner. 

Let’s Sum Up 

Input devices are essential components of computer systems that enable users to 

interact and input data. They encompass a variety of tools such as keyboards, mice, 

scanners, and touchscreens, each designed to facilitate different forms of input. These 

devices translate physical actions or data into signals that computers can process, making 

them fundamental to user interaction and data entry in both personal and professional 

computing environments. 

 

Check your Progress 

1. Which of the following is not an input device? 

A) Keyboard 

B) Mouse 

C) Monitor 

D) Scanner 

Answer: C) Monitor 

2. Which input device is primarily used to enter textual information into a computer? 

A) Joystick 

B) Keyboard 

C) Microphone 

D) Touchpad 

Answer: B) Keyboard 
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3. Which of the following input devices is commonly used for gaming? 

A) Stylus 

B) Light Pen 

C) Joystick 

D) Webcam 

Answer: C) Joystick 

4. What type of input device is a touchscreen? 

A) Optical device 

B) Biometric device 

C) Pointing device 

D) Scanning device 

Answer: C) Pointing device 

5. Which input device is used to capture video images in real-time? 

A) Scanner 

B) Digital Camera 

C) Webcam 

D) Trackball 

Answer: C) Webcam 

1.6 OUTPUT UNITS: MONITORS 

Monitor is the most commonly used output device used to display results of 

processing. Pictures on monitor are formed with picture elements called PIXEL. 

 

1.6.1 CLASSIFICATION OF MONITORS 

CRT Monitor: CRT is Cathode Ray Tube is a big size and takes up a lot of desk space. It 

uses cathode ray tube to display video and graphics on the screen.  

LCD Monitor: LCD is Liquid Crystal Display uses a special type of liquid crystal to display 

video and graphics on the screen. It consumes very less power than CRT monitor. It is 

very lighter and more portable than the CRT monitor.  

LED Monitor: LED is Light Emitting Diodes. LED is the advance application of LCD. The 

LED monitor consumes lesser power. 
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Digital Monitor: A digital display that uses liquid crystal cells that change reflectivity in an 

applied electric field; used for portable computer displays and watches etc. active matrix 

screen. a type of LCD screen used for some portable computers; there is a separate circuit 

for each pixel. 

 

 

 

 

Analog Monitor: An analog monitor is a monitor capable of accepting continuously 

varying or analog signals from the video adapter for an infinite range of different colors. 

The majority of all CRT monitors are analog monitors and all flat-panel displays are digital. 
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1.6.2 CHARACTERISTICS OF MONITOR 

Size  The most important aspect of a monitor is its size. Screen sizes are 

measured in diagonal inches, the distance from one corner to 

another opposite corner diagonally.  

Resolution  The resolution of a monitor indicates how density the pixels are 

packed. Pixel is short for picture element.  

Band Width  The amount of data that can be transmitted in a fixed amount of 

time. For digital devices, the band width is usually expressed in bits 

or bytes per second (bps). For analog devices it is expressed in 

cycle per second or Hertz (Hz).  

Refresh Rate  Display monitors must be refresh many times per second. The 

refresh rate determines how many times per seconds the screen is 

to be red drawn. The refresh rate of a monitor is measured in Hertz. 

The faster the refreshers, the less the monitor flickers.  

Interlacing  It is a technique in which instead of scanning the image one line at a 

time, it scans alternately i.e. alternate lines are scanned at each 

pass. 

Dot per Inch  It is measured for the actual sharpness of the on screen image. This 

depends on both the resolution & the size of the image. Practical 

experience shows that a smaller screen has a sharper image at the 

same resolution than does a large screen.  

Dot Pitch  A measurement that indicates the vertical distance between each 

pixel on a display screen. It is measured in millimetre.  

Storage   

 

The Computer has an in-built memory where it can store a large 

amount of data.  

 

1.7 PRINTERS 

Printers are used to produce hard copy output. They print processing results on 

paper. Printers are divided into two main categories: Impact Printers & Non-Impact 

printers. 
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1.7.1 IMPACT PRINTERS AND ITS TYPES 

Impact printers print the characters by striking them on the ribbon, which is then 

pressed on the paper. These printers are of two types like, Dot Matrix Printer and Daisy 

Wheel Printer.   

 

1.7.2 DOT MATRIX PRINTER  

A dot matrix printer is an impact printer that creates characters and images by 

striking a print head, which contains a grid of small pins, against an ink ribbon to transfer 

ink onto paper. This process forms patterns of dots that collectively represent text and 

graphics. Known for their robustness and ability to print on multi-part forms and carbon 

copies, dot matrix printers are often used in environments where continuous, reliable 

printing is required, such as in warehouses, retail settings, and logistics. 

 

1.7.3 DAISY WHEEL PRINTERS 

Daisy wheel printers are impact printers that produce high-quality text by striking a 

wheel-shaped print head, known as a daisy wheel, against an ink ribbon to print characters 

on paper. Each "petal" of the daisy wheel contains a single character, and the wheel spins 

to position the correct character before it strikes. Commonly used in the 1970s and 1980s, 

these printers were known for their precision and ability to produce crisp, typewriter-like 

text, making them popular for professional and office use. 

 

Characteristics of Impact Printers are the following – 

 Very low consumable costs 

 Very noisy 

 Useful for bulk printing due to low cost 

 There is physical contact with the paper to produce an image 

These printers print with striking of hammers or pins on ribbon.  
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1.7.4 NON-IMPACT PRINTERS AND ITS TYPES 

Non-impact printers print the characters without using the ribbon. These printers print a 

complete page at a time, thus they are also called as Page Printers. These printers do not 

use striking mechanism for printing. They use electrostatic and laser technology. Quality 

and speed of these printers is better than Impact printers. These printers are of two types 

namely Laser printer and Inkjet Printer. 

 

1.7.5 LASER PRINTERS  

Laser printers are a ubiquitous technology in modern offices and homes, offering fast and 

high-quality printing solutions. Utilizing a laser beam to create an electrostatic image on a 

rotating drum, they employ toner, a fine powder, to transfer the image onto paper through 

a process of electro statically charged rollers. The paper is then fused with heat to produce 

crisp, smudge-resistant prints. Laser printers excel in handling large volumes of text 

documents and graphics with sharp detail and consistent output. Their efficiency, speed, 

and relatively low cost per page make them ideal for businesses and individuals seeking 

reliable printing solutions. 

 

1.7.6 INKJET PRINTERS 

Inkjet printers represent a ubiquitous technology in modern printing, employing 

microscopic droplets of ink to produce high-quality prints. These printers work by 

propelling tiny droplets of ink onto paper, creating text, images, or graphics with precision 

and vibrancy. They are favored for their versatility, capable of producing everything from 

documents to photographs with impressive detail and color accuracy. Inkjet printers find 

extensive use in homes, offices, and commercial settings due to their affordability, ease of 

use, and ability to produce both black-and-white and color outputs. 
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Characteristics of Non-impact Printers 

 Faster than impact printers  

 They are not noisy  

 High quality  

 Supports many fonts and different character size  

 

Let’s Sum Up 

Output devices are essential components of computer systems that convert processed 

data into human-readable form. Common types include monitors, which display visual 

information, printers for producing hard copies of documents or images, and speakers that 

output audio signals. Each device serves a specific purpose in conveying information to 

users, enhancing the usability and interaction with digital data. 

Check your Progress 

1. Which of the following is an output device? 

A) Keyboard 

B) Scanner 

C) Monitor 

D) Mouse 

Answer: C) Monitor 

2. What is the primary function of a printer? 

A) To input text and images into the computer 

B) To display information on the screen 

C) To store data in a digital format 

D) To produce a hard copy of digital documents 

Answer: D) To produce a hard copy of digital documents 

3. Which output device is used to project images and videos onto a large screen? 

A) Monitor 

B) Printer 

C) Projector 

D) Plotter 
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Answer: C) Projector 

4. Which of the following is a characteristic of a plotter? 

A) It displays images on a screen 

B) It prints text documents 

C) It produces high-quality graphics on paper 

D) It is used to input drawings 

Answer: C) It produces high-quality graphics on paper 

5. Which output device is most commonly used for displaying textual and graphical 

information in real-time? 

A) Speaker 

B) Monitor 

C) Plotter 

D) Printer 

Answer: B) Monitor 

1.8 OPERATING SYSTEM 

An operating system is a program that acts as an interface between the software 

and the computer hardware. It is an integrated set of specialized programs used to 

manage over all resources and operations of  the computer. It is specialized 

software that controls and monitors the execution of all other programs that reside 

in the computer, including application programs and other system software. 

Examples of computer operating systems 

• Microsoft Windows 10 

• ApplemacOS 

• Ubuntu Linux 

• Google Android 

• iOS 
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1.9 DOS (DISK OPERATING SYSTEM) 

DOS is a family of operating systems, primarily known for MS-DOS (Microsoft Disk 

Operating System), developed by Microsoft. It was popular during the 1980s and early 

1990s, especially on IBM PC-compatible computers. 

User Interface: DOS primarily features a command-line interface (CLI) where users 

interact with the system by typing commands. It lacks a graphical user interface (GUI) 

found in modern operating systems. 

Functionality: DOS provides basic file management, disk utilities, and limited multitasking 

capabilities. It is a single-user, single-tasking operating system, meaning it can run only 

one program at a time. 

Legacy: Although largely obsolete for mainstream computing, DOS remains influential in 

the history of personal computing and embedded systems. Some DOS-based applications 

and games are still in use today. 

1.10 WINDOWS 

Windows is a family of graphical operating systems developed by Microsoft. It dominates 

the desktop and laptop market, offering various versions tailored to different use cases, 

including home, professional, and server environments. User Interface: Windows features 

a graphical user interface (GUI) characterized by windows, icons, menus, and pointers 

(WIMP). Users interact with the system using mouse and keyboard inputs. 

Functionality: Windows provides a wide range of features and capabilities, including 

multitasking, multi-user support, networking, device management, multimedia support, and 

a vast ecosystem of software applications. 

Versions: Windows has evolved through numerous versions over the years, with notable 

releases such as Windows 95, Windows XP, Windows 7, Windows 10, and Windows 11. 

Each version introduces new features, improvements, and changes to the user interface 

and underlying architecture. 
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1.11 UNIX/LINUX 

Unix and its open-source variant Linux are powerful, multi-user, multitasking operating 

systems known for their stability, security, and flexibility. Unix was developed in the late 

1960s, while Linux was created in the early 1990s by Linus Torvalds.User Interface: 

Unix/Linux systems offer both command-line interface (CLI) and graphical user interface 

(GUI) options. The CLI, accessed through a terminal, provides powerful text-based tools 

and utilities, while the GUI, such as GNOME or KDE, offers a desktop environment similar 

to Windows. 

Let’s Sum Up 

Operating systems (OS) serve as crucial software that manage computer hardware 

and provide a user interface. Windows and macOS are prominent commercial OSs known 

for their user-friendly interfaces and broad software compatibility. Linux, an open-source 

OS, offers robust customization and is widely used in server environments due to its 

stability and security features. DOS, though largely obsolete, laid foundational principles 

for modern OS development, influencing subsequent systems with its command-line 

interface and simplicity. 

1.12 PROGRAMMING LANGUAGES 

A programming language is a set of commands, instructions, and other syntax use 

to create a software program. Languages that programmers use to write code are 

called "high-level languages." This code can be compiled into a "low-level 

language," which is recognized directly by the computer hardware. 
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1.12.1 MACHINE LANGUAGE 

Machine language is the lowest-level programming language that computers can 

understand and execute directly. It consists of binary code, represented by combinations 

of 0s and 1s, which correspond to specific instructions that the computer's CPU (Central 

Processing Unit) can execute. Each instruction in machine language corresponds to a 

specific operation that the CPU can perform, such as arithmetic calculations, data 

movement, or control flow. In machine language, a simple instruction might be represented 

as a sequence of binary digits like "10110010," which the CPU interprets as a specific 

operation. 

Characteristics: 

o Low-Level: Directly manipulates hardware components and registers. 

o Machine-Dependent: Instructions are specific to the CPU architecture. 

o Difficult to Read and Write: Composed of binary digits, making it challenging 

for humans to understand and write directly. 

o Fast Execution: Executes directly by the CPU with minimal translation or 

interpretation overhead. 

1.12.2 ASSEMBLY LANGUAGE 

Assembly language is a low-level programming language that provides a symbolic 

representation of machine language instructions. It uses mnemonic codes to represent 

machine instructions, making it easier for humans to read and write compared to machine 

language. Assembly language instructions are mnemonic representations of machine 

language instructions. Each mnemonic corresponds to a specific machine instruction. 

Instead of writing binary code directly, programmers write assembly language code using 

mnemonics like "MOV" for move, "ADD" for addition, etc. 

Characteristics: 

o Human-Readable: Uses mnemonic codes and symbols that are easier for 

humans to understand compared to binary code. 

o Platform-Specific: Assembly language instructions are specific to the CPU 

architecture and platform. 

o Low-Level: Provides direct control over hardware components and registers. 
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o Assembler Required: Assembly code needs to be translated into machine 

code using an assembler before it can be executed by the CPU. 

o Close to Hardware: Allows programmers to access and manipulate hardware 

resources directly, offering fine-grained control. 

1.12.3 HIGH LEVEL LANGUAGE 

A high-level language is a computer programming language that isn't limited by 

the computer, designed for a specific job, and is easier to understand. It is more 

like human language and less like machine language. However, for a computer to 

understand and run a program created with a high-level language, it must be 

compiled into machine language. High-level languages are, 

• BASIC 

• C 

• C++ 

• COBOL 

• FORTRAN 

• Java 

• Pascal Perl 

• PHP 

• Python 

• Rub 

• Visual Basic 

Let’s Sum Up 

Programming languages can be broadly categorized into low-level and high-level 

languages. Low-level languages, such as assembly and machine code, are closer to the 

hardware and provide more control but are complex and harder to understand. High-level 

languages, like Python, Java, and C++, are more abstract, user-friendly, and efficient for 

developers, allowing them to write code that is easier to read, maintain, and debug. 

Check your Progress 

1. Which of the following is considered a low-level programming language? 

A) Python 

B) Assembly language 

C) Java 

D) C++ 

Answer: B) Assembly language 
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2. High-level programming languages are preferred over low-level languages 

because: 

A) They provide direct hardware control. 

B) They are more abstract and easier to read, write, and maintain. 

C) They are more complex and less user-friendly. 

D) They are slower and less efficient for developers. 

Answer: B) They are more abstract and easier to read, write, and maintain. 

3. Which statement is true regarding low-level languages? 

A) They are closer to human languages. 

B) They are easier to debug and maintain. 

C) They offer more control over hardware. 

D) They are generally slower to execute than high-level languages. 

Answer: C) They offer more control over hardware. 

4. Which of the following is NOT a high-level programming language? 

A) Python 

B) C++ 

C) Java 

D) Machine code 

Answer: D) Machine code 

5. Which of these is considered a high-level programming language? 

A) Assembly 

B) Machine code 

C) Python 

D) Binary code 

Answer: C) Python 
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1.13 Unit Summary  

 Input and output (I/O) devices facilitate communication between users and 

computers, enabling data entry and presentation of results. 

 These include keyboards, terminals, pointing devices, scanners, voice 

recognition systems, vision input systems, and touch screens, allowing users to 

input data through various means. 

 Monitors display visual output, while printers, including impact and non-impact 

printers, produce physical copies of data. Plotters create large-scale graphical 

outputs. 

 Primary storage, like RAM and ROM, is volatile and directly accessible by the 

CPU, while secondary storage, such as magnetic disks and optical disks, is 

non-volatile and used for long-term storage. 

 These are examples of different operating systems, each with its own features, user 

interfaces, and functionalities, catering to various user needs and preferences. 

1.14 Glossary  

 GUI - Graphical User Interface 

 CRT - Cathode Ray Tube  

 LCD - Liquid Crystal Display 

 LED - Light Emitting Diodes 

 RAM - Random Access Memory 

 ROM - Read Only Memory 

 PROM - Programmable Read-Only Memory 

 EPROM - Erasable Programmable Read-Only Memory 

 EEPROM - Electrically Erasable Programmable Read-Only Memory 

 CD - Compact Disc 

 DVD - Digital Versatile Disc 

 DOS - Disk Operating System 

 GUI - Graphical User Interface 

1.15 Self-Assessment Questions 

1. Describe any five input devices. 

2. Explain how a computer mouse works. 

https://www.geeksforgeeks.org/what-is-a-cd-compact-disk/
https://www.geeksforgeeks.org/dvd-full-form/
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3. Explain various types of scanners. 

4. Describe monitors and its types. 

5. Write a brief note on different types of printers. 

6. Classify operating systems 

1.16 Activity: " Identify and Categorize Devices " 

Objective: Understand and categorize different types of devices. 

Instructions: 

 Create a table listing the following devices: Keyboard, Mouse, Scanner, Monitor, 
Printer. 

 Categorize each as an input or output device. 
 Explain the primary function of each device in relation to the CPU. 

Output Example: 

Device Type Function 

Keyboard Input Allows user to input data and commands to the CPU 

Monitor Output Displays visual output from the CPU 

... ... ... 
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UNIT – II 

WORD PROCESSING 

 

UNIT II -    Word Processing 

Word Processing: Open, Save and close word document; Editing text – 

tools, formatting, bullets; Spell Checker - Document formatting – Paragraph 

alignment, indentation, headers, and footers, numbering, printing–Preview, 

options, merge. 
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2.4.1 Bullets 39 

2.4.2 Numbering 40 

2.4.3 Multilevel Lists 41 

2.5 Spell Checker 43 

2.6 Document Formatting 51 

2.6.1 Paragraph Alignment 51 

2.6.2 Indentation 54 

2.7 Headers and Footers 57 
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2.1 WORD PROCESSING 

Word processing refers to the creation, editing, formatting, and printing of 

documents using a computer program, typically referred to as a word processor. The 

primary goal of word processing software is to facilitate the efficient production of written 

documents, ranging from simple letters and memos to complex reports and manuscripts. 

Popular word processing programs include Microsoft Word, Google Docs, Apple Pages, 

and LibreOffice Writer. These programs offer various features such as spell-check, 

grammar-check, formatting options, templates, and collaboration tools, making it easier for 

users to create professional-looking documents. 

 

 

2.7.1 Adding Headers and Footers 58 

2.8 Printing and Preview Options 60 

2.9 Mail Merge 62 

2.10 Unit- Summary 65 

2.11 Glossary 65 

2.12 Self- Assessment Questions 65 

2.13 Activities / Exercises / Case Studies 66 

2.14 References  and Suggested Readings 68 

UNIT OBJECTIVES 

 This unit aims to understand the fundamental operations of word processing, 

including opening, saving, and closing documents in Microsoft Word.  

 Learners will explore proficiency in editing text using various tools and 

formatting options, including font styles, sizes, colors, and alignment, as well as 

the use of bullets for list formatting. 

 Learners will utilize the spell checker tool in Microsoft Word to identify and 

correct spelling errors in documents effectively. 
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2.1.1 OPEN WORD DOCUMENT 

To open a document in word processing software, you usually have several options: 

 File Menu: Many word processors have a "File" menu at the top left corner of the 

interface. Clicking on this menu and selecting "Open" will usually allow you to 

browse your computer's files and select the document you want to open. 

 

 

 

 

 

 Keyboard Shortcut: Most word processors also support keyboard shortcuts for 

opening documents. Common shortcuts include Ctrl + O (on Windows) or 

Command + O (on Mac) to open a new document.  

2.1.2 SAVE AND CLOSE WORD DOCUMENT 

Saving a document is crucial to preserve your work and ensure you can access it 

later. Here's how it's typically done: 
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 File Menu: Similar to opening a document, you can usually find the "Save" option 

under the "File" menu. Clicking "Save" will save your document with its current 

name and location. 

 Save As: If you want to save the document with a different name or in a different 

location, you can choose the "Save As" option. This allows you to specify a new 

name and location for the document. 

 

 

 

 

 

 

 

 

 

 

 Keyboard Shortcut: Keyboard shortcuts like Ctrl + S (on Windows) or Command + 

S (on Mac) are commonly used to quickly save a document. 

 File Menu: Like opening and saving, you can typically find an option to close the 

document under the "File" menu. Selecting "Close" will close the active document. 

 Close Button: Many word processors have a close button (usually an "X" icon) in 

the top-right corner of the window. Clicking this button will also close the 

document. 
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 Keyboard Shortcut: Some word processors support keyboard shortcuts for 

closing documents, often using Ctrl + W (on Windows) or Command + W (on 

Mac). 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Let’s Sum Up 

In Microsoft Word, the fundamental operations of opening, saving, and closing 

documents are essential for creating and managing files. Opening allows users to access 

existing documents, saving preserves changes and ensures data integrity, while closing 

ends the editing session, maintaining document organization and security. 

2.2 EDITING TEXT 

Before you can edit text, you often need to select it. This can be done by clicking 

and dragging the mouse cursor over the text you want to select or by using keyboard 

shortcuts like Shift + Arrow keys to extend the selection. 
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2.2.1 BASIC TEXT EDITING 

 Typing: Simply start typing to add new text to your document. 

 Deleting: Use the Backspace key to delete text to the left of the cursor, and the 

Delete key to delete text to the right of the cursor. 

 Cut, Copy, and Paste: These actions allow you to move or duplicate text within 

the document or between documents. 

 Cut (Ctrl + X): Removes the selected text from its original location 

and places it in the clipboard. 

 Copy (Ctrl + C): Copies the selected text to the clipboard without 

removing it from its original location. 

 Paste (Ctrl + V): Inserts the contents of the clipboard at the cursor 

position. 
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Let’s Sum Up 

MS Word provides powerful tools for editing documents, offering features like track 

changes, formatting options, and collaboration tools that streamline the editing process. Its 

user-friendly interface and comprehensive functionality make it indispensable for creating 

and refining professional documents efficiently. 

2.3 FORMATTING TEXT 

Formatting text in Microsoft Word involves adjusting the appearance of the text to 

enhance readability, emphasize key points, and create a visually appealing document. 

Here are the main aspects and tools for formatting text in MS Word: 

1. Font and Font Size 

 Changing Font: Select the text you want to change, go to the "Home" tab, and 

choose a font from the "Font" drop-down menu. 

 Changing Font Size: Select the text, go to the "Home" tab, and choose a size from 

the "Font Size" drop-down menu or type a size directly. 
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2. Font Styles 

1. Bold, Italic, Underline: Select the text and click on the "B" (Bold), "I" (Italic), or "U" 

(Underline) buttons in the "Home" tab. 

2. Strikethrough: Select the text, and click the "Strikethrough" button in the "Home" tab. 

3. Subscript and Superscript: Select the text, and click the "Subscript" (X₂) or 

"Superscript" (X⁴) buttons. 

3. Font Color and Highlighting 

 Font Color: Select the text, go to the "Home" tab, click on the "Font Color" button 

(an A with a colored underline), and choose a color. 

 Text Highlighting: Select the text, go to the "Home" tab, click the "Text Highlight 

Color" button, and choose a highlight color. 

4. Paragraph Formatting 

 Alignment: Select the text and choose alignment options from the "Paragraph" 

group in the "Home" tab: Left, Center, Right, or Justify. 

 Line Spacing: Select the text, click on the "Line and Paragraph Spacing" button in 

the "Home" tab, and choose a spacing option. 

 Indentation: Adjust the left and right indentation using the indent markers on the 

ruler or through the "Paragraph" dialog box. 
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5. Lists 

 Bulleted and Numbered Lists: Select the text, go to the "Home" tab, and click the 

"Bullets" or "Numbering" buttons. 

 Multilevel Lists: Use the "Multilevel List" button to create hierarchical lists. 

6. Styles 

 Applying Styles: Use predefined styles to ensure consistency. Go to the "Home" 

tab and select a style from the "Styles" gallery. 

 Modifying Styles: Right-click on a style in the "Styles" gallery and choose "Modify" 

to change its formatting. 

7. Themes 

 Applying Themes: Go to the "Design" tab and choose a theme that applies a 

coordinated set of fonts, colors, and effects to the entire document. 

 Customizing Themes: Modify theme colors, fonts, and effects in the "Design" tab 

to create a custom look. 
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8. Text Effects 

 WordArt: Insert decorative text using WordArt. Go to the "Insert" tab, click 

"WordArt," and choose a style. 

 Text Effects: Apply effects like shadow, reflection, glow, or 3D effects from the 

"Text Effects" menu in the "Home" tab. 

9. Columns 

 Creating Columns: Split text into columns by selecting the text, going to the 

"Layout" tab, and clicking the "Columns" button. 

10. Headers and Footers 

 Adding Headers and Footers: Go to the "Insert" tab, click on "Header" or "Footer," 

and choose a style. Add text, dates, or page numbers. 

11. Page Setup 

 Margins: Adjust page margins from the "Layout" tab by clicking the "Margins" 

button. 

 Orientation: Change the page orientation to portrait or landscape from the "Layout" 

tab. 

12. Tables 

 Inserting Tables: Go to the "Insert" tab, click "Table," and choose the dimensions. 

 Formatting Tables: Use the "Table Tools" tab to apply styles, adjust cell sizes, and 

format borders. 

13. Styles and Templates 

 Using Templates: Start with a pre-designed template from the "File" menu to 

ensure consistent formatting. 

 Customizing Styles: Create and save custom styles for specific formatting needs. 
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Let’s Sum Up 

Microsoft Word is a versatile tool for document formatting, offering features such as 

font styles, paragraph alignment, and page layout customization. Users can create 

professional-looking documents by adjusting margins, inserting headers and footers, and 

utilizing templates for consistency. Its robust editing capabilities, including spell check, 

grammar correction, and track changes, make it indispensable for both personal and 

professional use, ensuring documents are polished and visually appealing. 

Check Your Progress 

 

1. Which of the following options is used to change the text alignment in MS Word? 

A) Home → Paragraph 

B) Insert → Table 

C) View → Outline 

D) Review → Language 

Answer: A) Home → Paragraph 

2. How can you make text bold in MS Word? 

A) Press Ctrl + U 

B) Press Ctrl + I 
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C) Press Ctrl + B 

D) Press Ctrl + O 

Answer: C) Press Ctrl + B 

3. To apply a predefined style to a selected text, which tab should you use in MS 

Word? 

A) Review 

B) Home 

C) Insert 

D) References 

Answer: B) Home 

4. How can you change the font size of a selected text in MS Word? 

A) Insert → Font 

B) Layout → Size 

C) Home → Font Size 

D) Review → Font 

Answer: C) Home → Font Size 

5. Which of the following is used to change the line spacing of text? 

A) Home → Paragraph → Line Spacing 

B) Insert → Line 

C) File → Options 

D) View → Layout 

Answer: A) Home → Paragraph → Line Spacing 

2.4 BULLETS AND NUMBERING 

2.4.1 BULLETS 

Bullets and numbering in Microsoft Word are formatting tools used to create lists. They 

help organize information, making it easier to read and understand. Here's a detailed 

description of both features. Bulleted lists are used for items that do not need to be in a 

specific order. Each item is preceded by a symbol (bullet point), which can be customized. 
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Creating a Bulleted List: 

1. Select Text: Highlight the text you want to format as a list. 

2. Bullets Button: Click the "Bullets" button in the "Paragraph" group on the "Home" 

tab. 

3. Customize Bullets: Click the dropdown arrow next to the "Bullets" button to choose 

different bullet styles or define a new bullet. 

Customizing Bullets: 

3 Symbol: You can choose from a variety of symbols. 

4 Picture: You can use an image as a bullet. 

5 Font: Customize the font style, size, and color of the bullet. 

Numbered lists are used for items that need to be in a specific order, such as instructions 

or steps in a process. Each item is preceded by a number or letter. 

2.4.2 NUMBERING 

Numbering in Microsoft Word is used to organize and structure your documents by 

adding numbers to paragraphs, lists, headings, and other elements. It enhances 

readability and makes it easier to refer to specific sections or items. Here’s how you can 

use numbering effectively in MS Word. 
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1. Numbered Lists 

Numbered lists are useful for creating ordered lists, such as steps in a procedure or 

ranked items. 

 Select the text you want to format as a numbered list, or place the cursor where you 

want to start the list. 

 Go to the Home tab. 

 Click the Numbering button in the Paragraph group (it looks like a numbered list). 

 Click the arrow next to the Numbering button to choose different numbering formats 

(e.g., 1., 2., 3. or I., II., III.). 

 Select Define New Number Format to customize the appearance of the numbers. 

4. Customizing Number Formats 

 Select the numbered text. 

 Go to the Home tab. 

 Click the arrow next to the Numbering or Multilevel List button. 

 Select Define New Number Format or Define New Multilevel List. 

 Choose the number style, font, and alignment options. 

5. Restarting or Continuing Numbering 

 Right-click on the number where you want to restart the numbering. 

 Select Restart at 1 from the context menu. 

 Right-click on the number where you want to continue numbering from a previous 

list. 

 Select Continue Numbering from the context menu. 

 

2.4.3. MULTILEVEL LISTS 

Multilevel lists combine both bullets and numbering, allowing you to create a hierarchical 

structure. This is useful for outlines or complex lists with sub-items. 

1. Select Text: Highlight the text you want to format as a list. 

2. Multilevel List Button: Click the "Multilevel List" button in the "Paragraph" group on 

the "Home" tab. 

3. Customize List: Click the dropdown arrow next to the "Multilevel List" button to 

choose different styles or define a new multilevel list. 
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Let’s Sum Up 

In Microsoft Word, bulleting and numbering are essential tools for organizing and 

structuring documents effectively. Bullets are used to list items without any particular 

order, ideal for creating lists of items or points. Numbering, on the other hand, 

automatically applies sequential numbers, making it perfect for creating ordered lists such 

as steps in a procedure or chapters in a report. Both features enhance readability and 

clarity, ensuring that information is presented logically and comprehensibly within the 

document. 

Check Your Progress 

1. Which tab in MS Word is used to access the bullet and numbering options? 

A) Insert 

B) Home 

C) Design 

D) View 

Answer: B) Home 

2. How can you customize the bullet style in a list in MS Word? 

A) By using the Font settings 

B) By selecting "Define New Bullet" under the Bullet dropdown menu 

C) By changing the Page Layout 

D) By modifying the Paragraph settings 

Answer: B) By selecting "Define New Bullet" under the Bullet dropdown menu 

3. Which of the following keyboard shortcuts can be used to create a bullet point in 

MS Word? 

A) Ctrl + Shift + L 

B) Ctrl + B 

C) Alt + N 

D) Ctrl + M 

Answer: A) Ctrl + Shift + L 
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4. If you want to create a multi-level list in MS Word, which option should you 

select? 

A) Numbering 

B) Bullets 

C) Multilevel List 

D) Indent 

Answer: C) Multilevel List 

5. How can you restart numbering in a numbered list in MS Word? 

A) Right-click the number and choose "Restart at 1" 

B) Press Enter twice 

C) Use the Format Painter 

D) Change the font size 

Answer: A) Right-click the number and choose "Restart at 1" 

  

2.5 SPELL CHECKER 

 

Microsoft Word has a special feature called spell check that allows you to check 

spelling and grammatical mistakes that you made in the document. Basically spell check 

is a software tool that identifies the misspelled words present in the document. It also 

allows you to search a particular word in the document that you know you’ve misspelled 

in the whole document.  

In Microsoft Word documents, Word’s spell check function is set to automatically 

check your spelling while you type. Errors in your document will have color-coded 

underlines reflecting your choices, like red for spelling errors, green for grammar errors, 

and blue for contextual spelling errors. 
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Steps to enable Spell Checker in MS Word 

Step 1: On the navigation menu bar click on the File option. 
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Step 2: Next click on the option button as shown in the figure: 

 

Step 3: A word option dialog box will appear on the screen. 
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Step 4: Now select the Proofing option from the left menu as shown in the figure: 

 

Step 5: Check all boxes as shown in the figure: 
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Step 6: Next click on the OK button. 

 

Finally, Spell Check is enabled in MS Word. 

How to Manually Check Spellings  

Step 1: On the navigation menu bar click on the Review option. 

 

Step 2: Next click on the spellings & grammar option as shown in the figure: 

 



CDOE - ODL B.SC (COMPUTER SCIENCE) – SEMESTER IV UNIT - II 

 

48 Periyar University – CDOE| Self-Learning Material 

 

Note – If there is any spelling or grammatical mistake in your Word document, then 

the following dialog box appears with misspelled words present in the red 

underlined text. 

 

Step 3: If there is a spelling mistake in the document then it will appear in the red 

underline text as shown in the figure: 
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Step 4: Select the correct spelling from the suggestion menu. 

 

 

Step 5: Next click on the YES option. 

 

 

Let’s Sum Up 

Microsoft Word's spell-checking feature has revolutionized document processing by 

ensuring accurate spelling and grammar across various types of content. It automatically 

detects and corrects errors, improving the overall quality and professionalism of 

documents. This tool has become indispensable for writers, students, and professionals 

alike, streamlining the editing process and enhancing communication effectiveness. 
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Check Your Progress 

1. Which feature in MS Word automatically checks the spelling as you type? 

A) Grammar Checker 

B) AutoCorrect 

C) Spell Check 

D) Thesaurus 

Answer: C) Spell Check 

2. What is the default shortcut key to run the spell check in MS Word? 

A) F2 

B) F5 

C) F7 

D) Shift + F7 

Answer: C) F7 

3. How does MS Word indicate a misspelled word in the document? 

A) Blue wavy underline 

B) Green wavy underline 

C) Red wavy underline 

D) Yellow highlight 

Answer: C) Red wavy underline 

4. Which tab in MS Word contains the Spell Check feature? 

A) Insert 

B) Review 

C) Home 

D) References 

Answer: B) Review 

5. What happens when you add a word to the MS Word dictionary? 

A) The word will be ignored for the rest of the document. 

B) The word will be deleted. 

C) The word will be automatically corrected in the future. 

D) The word will no longer be marked as a spelling error in all documents. 

Answer: D) The word will no longer be marked as a spelling error in all documents. 
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2.6 DOCUMENT FORMATTING 

Microsoft Word provides several options for formatting text to enhance readability 

and emphasize important content. Here’s how to apply bold, italics, underline, and 

strikethrough formatting: 

2.6.1 PARAGRAPH ALIGNMENT 

Paragraph alignment in Microsoft Word refers to the way text lines up within the 

margins of your document. Aligning text properly can greatly improve the readability and 

visual appeal of your document. Here are the steps to adjust paragraph alignment: 
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Left Align 

 Aligns text to the left margin, leaving the right margin uneven. This is the default 

alignment for most documents. 

 Using the Ribbon: Select the paragraph(s) you want to align. Go to the Home tab 

and click the Left Align button (Align Left icon) in the Paragraph group. 

 Keyboard Shortcut: Select the paragraph(s) and press Ctrl + L (Cmd + L on Mac). 

Center Align 

 Centers text between the left and right margins, giving a more formal and balanced 

look. 
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 Using the Ribbon: Select the paragraph(s) you want to center. Go to the Home tab 

and click the Center Align button (Center icon) in the Paragraph group. 

 Keyboard Shortcut: Select the paragraph(s) and press Ctrl + E (Cmd + E on Mac). 

Right Align 

 Aligns text to the right margin, leaving the left margin uneven. This can be useful for 

special formatting or emphasis. 

 Using the Ribbon: Select the paragraph(s) you want to align. Go to the Home tab 

and click the Right Align button (Align Right icon) in the Paragraph group. 

 Keyboard Shortcut: Select the paragraph(s) and press Ctrl + R (Cmd + R on Mac). 

Justify 

 Aligns text evenly along both the left and right margins, adding extra space between 

words as necessary. This creates a clean and polished look often used in 

newspapers and books. 

 Using the Ribbon: Select the paragraph(s) you want to justify. Go to the Home tab 

and click the Justify button (Justify icon) in the Paragraph group. 

 Keyboard Shortcut: Select the paragraph(s) and press Ctrl + J (Cmd + J on Mac). 

Additional Paragraph Formatting Options 

 Select the paragraph(s). 

 Go to the Home tab. 

 Click the Line and Paragraph Spacing button in the Paragraph group. 

 Choose a spacing option from the dropdown menu (e.g., 1.0, 1.15, 1.5, 2.0). 

 Choose Add Space Before Paragraph or Remove Space After Paragraph. 

 Use the Increase/Decrease Indent buttons to adjust indentation. 
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2.6.2 INDENTATION 

Indentation in Microsoft Word helps to improve the structure and readability of your 

document by adding space at the beginning of lines or paragraphs. There are several 

types of indentations that apply to paragraphs in a Word document. Indentation in 

Microsoft Word can be adjusted using the Paragraph dialog box. This feature allows you to 

control the distance between the text and the page margins, both on the left and right 

sides, and to set special indentations such as a first line or hanging indent. Here’s how to 

use the Paragraph dialog box to adjust indentation: 
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Indentation Settings: 

 In the Paragraph dialog box, you will find the "Indentation" section. 

 Left: This controls the space added to the left margin of the paragraph. Increase the 

value to move the paragraph text to the right. 

 Right: This controls the space added to the right margin of the paragraph. Increase 

the value to move the paragraph text to the left. 

 Special: This dropdown menu allows you to select special indentation types: 

 First line: Indents only the first line of the paragraph. The value entered in the "By" 

box determines the amount of indentation. 

 Hanging: Indents all lines of the paragraph except the first line. The value entered 

in the "By" box determines the amount of indentation. 
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Adjusting Indentation: 

 To set a first line indent, choose "First line" from the "Special" dropdown and enter 

the desired measurement in the "By" field. 

 To set a hanging indent, choose "Hanging" from the "Special" dropdown and enter 

the desired measurement in the "By" field. 

 To set a standard left or right indent, simply enter the desired measurements in the 

"Left" and "Right" fields. 

Preview and Apply: 

 As you adjust the settings, the preview box at the bottom of the dialog box will show 

you a visual representation of the paragraph with the new indentation settings. 

 Once you are satisfied with the settings, click "OK" to apply the changes to the 

selected paragraphs. 

Let’s Sum Up 

MS Word's document formatting capabilities empower users to create professional-

looking documents with ease. From adjusting fonts, margins, and spacing to incorporating 

headers, footers, and page numbering, Word provides a robust suite of tools for precise 

customization. Its intuitive interface and extensive formatting options make it indispensable 

for crafting everything from reports and resumes to newsletters and academic papers. 
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2.7 HEADERS AND FOOTERS 

Headers and footers are sections at the top and bottom of each page in a Word 

document. They can contain text, page numbers, dates, logos, and other information that 

you want to repeat on every page or in specific sections of your document. 
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2.7.1 ADDING HEADERS AND FOOTERS 

Adding headers and footers in Microsoft Word is a straightforward process that can 

enhance the structure and appearance of your documents. Here's a detailed guide on how 

to add headers and footers: 

1. Open your document: 

o Launch Microsoft Word and open the document where you want to add 

headers and footers. 

2. Access the Header and Footer tools: 

o Go to the "Insert" tab on the Ribbon. 

o In the "Header & Footer" group, you will see options for "Header," "Footer," 

and "Page Number." 

3. Insert a Header: 

o Click on the "Header" button. 

o A drop-down menu will appear with several predefined header styles. 

o Select a style from the list or choose "Edit Header" to create a custom 

header. 

o Once you select an option, the header section will become active, and you 

can type the text or insert elements such as date, time, or pictures. 

4. Insert a Footer: 

o Click on the "Footer" button. 

o A drop-down menu will appear with several predefined footer styles. 

o Select a style from the list or choose "Edit Footer" to create a custom footer. 

o Once you select an option, the footer section will become active, and you 

can type the text or insert elements such as page numbers, date, or other 

details. 

5. Insert Page Numbers: 

o Click on the "Page Number" button if you want to add page numbers. 

o A menu will appear with options to position the page numbers (Top of Page, 

Bottom of Page, Page Margins, etc.). 

o Choose the desired position and format for the page numbers. Word will 

automatically insert and update the page numbers throughout your 

document. 
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6. Customize Headers and Footers: 

o While in the header or footer editing mode, you can use the tools on the 

"Header & Footer Tools" tab that appears on the Ribbon. 

o You can set different headers and footers for odd and even pages, for the 

first page, or for different sections of your document. 

o To switch between the header and footer, use the "Go to Footer" or "Go to 

Header" button on the "Header & Footer Tools" tab. 

7. Exit the Header and Footer: 

o After making your changes, click the "Close Header and Footer" button on 

the Ribbon, or double-click anywhere outside the header or footer area to 

return to the main document. 

 Different First Page: If you need a different header or footer for the first page, 

check the "Different First Page" box in the "Header & Footer Tools" tab. This is 

useful for title pages or cover pages. 

 Section Breaks: To have different headers and footers in different sections of your 

document, insert section breaks (found under the "Layout" or "Page Layout" tab), 

and then edit the headers and footers for each section. 

 Link to Previous: If you want the header or footer in a new section to be the same 

as in the previous section, use the "Link to Previous" option in the "Header & Footer 

Tools" tab. Deselect this option if you want to create a unique header or footer for 

the new section. 

Let’s Sum Up 

Headers and footers in Microsoft Word documents serve crucial organizational and 

navigational purposes. They typically contain page numbers, document titles, dates, and 

other relevant information, ensuring consistency and professionalism throughout the 

document. Customizable across sections, headers and footers enhance document 

usability by providing contextual details without interrupting the main content flow, 

facilitating easier navigation and identification of document sections. 
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2.8 PRINTING AND PREVIEW OPTIONS 

In Microsoft Word, the printing process includes several steps and features to ensure your 

document is printed correctly and meets your specific needs. These features include 

previewing the document, selecting printing options, and merging documents for printing. 

1. Print Preview 

Print Preview allows you to see how your document will look once printed. This helps in 

identifying any formatting issues, page breaks, and overall layout before sending the 

document to the printer. 

 Accessing Print Preview: You can access Print Preview by clicking on File>Print, 

or by pressing Ctrl + P. This opens the Print pane where the preview is displayed on 

the right side of the screen. 

 Features in Print Preview: 

o Zoom In/Out: You can zoom in to see details or zoom out to view the entire 

page. 

o Navigate Pages: Use the navigation arrows to move between pages of the 

document. 

o Adjust Settings: Directly change print settings such as orientation, paper 

size, and margins. 

2. Printing Options 

Microsoft Word provides a variety of printing options to customize how your document is 

printed. 

 Print Range: 

o All Pages: Print the entire document. 

o Current Page: Print only the page currently being viewed. 

o Selection: Print only the selected text. 

o Custom Range: Specify specific pages or a range of pages to print (e.g., 1-

3, 5, 7-10). 

 Number of Copies: Specify the number of copies you want to print. 
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 Printer Selection: Choose from the list of available printers connected to your 

computer or network. 

 Page Setup Options: 

o Orientation: Select between Portrait and Landscape mode. 

o Paper Size: Choose the size of the paper (e.g., A4, Letter). 

o Margins: Adjust the margins for the document. 

 Collation: Choose whether to collate copies or not when printing multiple copies of 

a multi-page document. 

 Duplex Printing: Select double-sided printing if supported by your printer. 

 Print Quality: Choose the quality of the print, which can affect print speed and ink 

usage. 
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Let’s Sum Up 

In Microsoft Word, the print option allows users to create physical copies of 

documents directly from the application. It provides essential settings for adjusting page 

layout, selecting printers, and previewing documents to ensure accurate and professional 

printing results. 

Check Your Progress 

1. Microsoft word is ____ software. 

A) Application B) Compiler  C) System  D) Programming 

Answer: A) Application 

2. The ___ works with the standard Copy and Paste commands. 

   A) View Tab  B) Paragraph Dialog Box C) Office Clipboard D) All Of These 

Answer: C) Office Clipboard 

3. What is the blank space outside the printing area on a page? 

   A) Clipart    C) Header  D) Footer 

Answer: B) Margins 

4. Which of the following is an example of page orientation? 

   A) Landscape B) Subscript  C) Superscript D) A4 

Answer: A) Landscape 

5. Which enables us to send the same letter to different people? 

      A) Macros B) Template  C) Mail Merge D) None Of Above 

Answer: C) Mail Merge 

 

2.9 MAIL MERGE 

Mail Merge in Microsoft Word is a powerful feature that allows users to create a batch of 

documents that are personalized for each recipient. These documents can include letters, 

labels, envelopes, and emails, among others. The key benefit of using Mail Merge is its 
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ability to automate the customization process, saving time and effort when creating large 

volumes of personalized documents. 

Components of Mail Merge 

1. Main Document: This is the template that contains the static content and 

placeholders (also known as merge fields) for the variable data. Examples of main 

documents include a form letter or a standard email message. 

2. Data Source: This is the file that contains the data to be merged into the main 

document. It can be a spreadsheet, a database, or even an Outlook contact list. 

Common data sources include Microsoft Excel files, CSV files, and Access 

databases. 

3. Merge Fields: These are placeholders in the main document that correspond to the 

columns in the data source. Examples of merge fields include <<FirstName>>, 

<<LastName>>, and <<Address>>. 

 

Steps to Perform Mail Merge 

1. Prepare the Main Document: Create the document in Word that will serve as your 

template. This document should contain the fixed text and placeholders for the data 

that will be merged. 
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2. Set Up the Data Source: Ensure your data source is well-organized, with a clear 

header row identifying each column (e.g., FirstName, LastName, Address). 

3. Link the Data Source to the Main Document: 

o Go to the Mailings tab in Word. 

o Click Start Mail Merge and choose the type of document you are creating 

(e.g., Letters, E-mail Messages, Envelopes, Labels, or Directory). 

o Click Select Recipients and choose your data source. 

4. Insert Merge Fields: 

o Position the cursor in the main document where you want to insert the merge 

field. 

o Click Insert Merge Field and select the field you want to insert. Repeat this 

step for all the fields you need. 

5. Preview the Merged Document: 

o Click Preview Results to see how the merged document will look for each 

recipient. 

o Use the navigation arrows to view each record's merged document. 

6. Complete the Merge: 

o Click Finish & Merge and choose whether you want to edit individual 

documents, print documents, or send them via email. 

Practical Applications 

 Form Letters: Send personalized letters to multiple recipients with individualized 

greetings, names, addresses, and other details. 

 Labels: Create mailing labels for a large list of addresses. 

 Envelopes: Print envelopes with recipient addresses from a contact list. 

 Emails: Send customized email messages to a group of people, each message 

tailored with the recipient's information. 

 

Let’s Sum Up 

Mail merge in MS Word enables users to create personalized documents efficiently by 

merging a template with a data source, such as a spreadsheet. It streamlines the process 
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of generating bulk letters, emails, or labels, ensuring each recipient receives customized 

content based on specific data fields. 

2.10 Unit Summary 

 It focuses on word processing skills using Microsoft Word, covering essential 

operations and functionalities for creating and formatting documents effectively. 

 Develop proficiency in using various tools and formatting options to customize the 

appearance of text within documents.  

 Utilize the spell checker tool to ensure accurate spelling in their documents. 

 Document formatting techniques include paragraph alignment, indentation, and the use 

of headers and footers for document customization. 

 

2.11 Glossary  

 Ribbon - Tabs with groups of related commands and features. 

 Quick Access Toolbar - A customizable toolbar for frequently used commands. 

 Document Window - The area where the content of the document is displayed and 

edited. 

 Status Bar - Displays information about the current document, such as page number 

and word count. 

 Contextual Menu - A menu that appears when right-clicking, showing commands 

relevant to the current selection. 

 Template - A pre-designed document format that can be used to create new 

documents with a similar layout and style. 

 Styles - Predefined combinations of formatting attributes that can be applied to text for 

consistent formatting. 

 

2.12 Self-Assessment Questions 

1. Describe the process of saving a new document in Word. 

2. How can you edit text in a Word document? Name two text editing tools or 

functions you can use. 

3. What is the purpose of using bullets in a Word document? How can you add 

bullets to a list? 
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4. Describe the function of the spell checker in Word. How can you access and 

use the spell checker tool? 

5. Discuss three formatting options you can apply to paragraphs in Word. 

 

2.13 Case Study: “Document Preparation for a Research Proposal” 

Scenario: 

You are preparing a research proposal document for your upcoming project on “Innovative 

Approaches in Leukemia Treatment”. The document needs to be professional, well-

structured, and free from errors. You will create, edit, and format this document using the 

following tasks: 

Tasks: 

1. Creating and Saving a New Document: 

o Open a new Word document and save it with the filename: 

Leukemia_Research_Proposal.docx. 

o Create a title page with the title "Innovative Approaches in Leukemia 

Treatment" and your name, affiliation, and date. Use appropriate formatting 

and alignment for a professional appearance. 

2. Editing and Formatting Text: 

o Add a section titled “Introduction” and write a brief introduction about 

Leukemia and the purpose of the research. 

o Use the following formatting tools: 

 Bold the first sentence of the introduction. 

 Italicize technical terms such as “Leukemia” and “Treatment”. 

 Use a different font (e.g., Times New Roman, size 12) for the body 

text. 

 Use the “Heading 1” style for section titles. 

3. Using Bullets and Numbering: 

o Create a list of objectives under the section “Objectives” using bullet points. 

o Create a numbered list under the section “Methodology” to outline the steps 

of your proposed research approach. 
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4. Spell Checker: 

o Run a spell check on the document to ensure there are no spelling errors. 

Correct any mistakes found. 

5. Document Formatting: 

o Align the text in the “Introduction” section to be justified. 

o Indent the first line of each paragraph in the “Introduction” and “Methodology” 

sections. 

o Insert a header with the title of your research proposal and a footer with the 

page number. 

6. Headers and Footers: 

o Insert a header with the title “Leukemia Research Proposal” on all pages. 

o Insert a footer with your name on the left and the page number on the right. 

7. Page Numbering and Page Setup: 

o Start page numbering from the “Introduction” section, excluding the title 

page. 

o Adjust the margins to 1 inch on all sides for a neat appearance. 

8. Printing and Preview: 

o Use the “Print Preview” option to check the overall layout of your document. 

o Explore different printing options such as single-sided and double-sided 

printing. 

9. Document Merging: 

o Assume you have another document containing a “Literature Review” 

section. Use the “Insert” or “Merge” feature to include this section into your 

main document. 

10. Saving and Closing: 

o Save the final version of your document. 

o Close the document after saving. 

Outcome: 

By completing these tasks, you will have a well-formatted research proposal document 

that demonstrates your proficiency in word processing. The document will be structured, 

error-free, and ready for submission or printing. 



CDOE - ODL B.SC (COMPUTER SCIENCE) – SEMESTER IV UNIT - II 

 

68 Periyar University – CDOE| Self-Learning Material 

 

2.14 References and Suggested Readings  

1. Peter Norton, Introduction to Computers–Tata McGraw-Hill. 

2. Jennifer Ackerman Kettel, Guy Hat-Davis, Curt Simmons, ―Microsoft 

2003‖, Tata McGrawHill 

3. TorbenLageFrandsen, Microsoft Office Word, 2010 

 

*************************************** 

UNIT - II COMPLETED

https://www.google.co.in/search?sca_esv=9d633321853007a8&sca_upv=1&hl=en&sxsrf=ADLYWIKG24VUraPlueht2NkC8JVz6h-rOg:1717756160893&q=inauthor:%22Torben+Lage+Frandsen%22&tbm=bks


CDOE - ODL B.SC (COMPUTER SCIENCE) – SEMESTER IV UNIT - III 

 

69 Periyar University – CDOE| Self-Learning Material 

 

UNIT – III 

SPREADSHEETS 

 

UNIT III -    SPREADSHEETS 

Spreadsheets: Excel– opening, entering text and data, formatting, 

navigating; Formulas– entering, handling and copying; Charts–creating, 

formatting and printing, analysis tables, preparation of financial statements, 

introduction t o data analytics 
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3.7.1 Creating A Chart 85 
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3.1 INTRODUCTION 

MS-EXCEL is a part of Microsoft Office suite software. It is an electronic 

spreadsheet with numerous rows and columns, used for organizing data, graphically 

representing data(s), and performing different calculations.  It consists of 1048576 rows 

and 16384 columns, a row and column together make a cell. Each cell has an address 

defined by column name and row number example A1, D2, etc. This is also known as a 

cell reference. 

Microsoft Excel is a software application designed for creating tables to input and 

organize data. It provides a user-friendly way to analyze and work with data. The image 

below provides a visual representation of what an Excel spreadsheet typically appears like 
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UNIT OBJECTIVES 

 In this unit aims to understand the fundamental features of Excel, including 

opening and navigating through workbooks, entering text and data, and basic 

formatting techniques.  

 Learners will be able to develop proficiency in entering, handling, and copying 

formulas in Excel, including basic arithmetic operations, functions, and formula 

referencing.  

 Furthermore, this unit explore the basics of data analytics in Excel, including 

data manipulation, visualization, and basic statistical analysis techniques. 
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3.2 EXCEL OPENING 

Launch Microsoft Excel from your start menu or applications folder. 

Windows: Click on the Start menu, type "Excel" in the search bar, and select Microsoft 

Excel from the list of results. 

Mac: Open Finder, go to the Applications folder, and double-click on Microsoft Excel. 

Excel Interface Overview: 

Title Bar: Displays the name of the workbook. 

Ribbon: Contains tabs (Home, Insert, Page Layout, etc.) with various tools and options. 

Workbook: A file containing one or more worksheets. 

Worksheet: A grid of cells where you can enter data. Each worksheet has rows 

(numbered) and columns (lettered). 

Formula Bar: Displays the contents of the selected cell and allows you to enter or edit 

data and formulas. 

Status Bar: Located at the bottom, it provides information about the current mode and 

includes tools like zoom control. 

 

3.3 ENTERING TEXT AND DATA 

1. Open Excel: 

 Launch the Microsoft Excel application on your computer. 

2. Creating or Opening a Workbook: 

 Create a new workbook: Click on File > New > Blank Workbook. 

 Open an existing workbook: Click on File > Open and select the file. 

3. Understanding Cells, Rows, and Columns: 

 Cells: The individual boxes you see on the worksheet. Each cell is identified by 

its column letter and row number (e.g., A1, B2). 

 Rows: Horizontal lines of cells, identified by numbers (1, 2, 3, ...). 

 Columns: Vertical lines of cells, identified by letters (A, B, C, ...). 
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4. Entering Text: 

 Click on the cell where you want to enter text. 

 Type the desired text. 

 Press Enter to move to the cell below or Tab to move to the cell to the right. 

5. Entering Numbers: 

 Click on the cell where you want to enter a number. 

 Type the number (e.g., 1234, 56.78). 

 Press Enter to confirm. 

6. Entering Dates and Times: 

 Click on the cell where you want to enter a date or time. 

 Type the date (e.g., 12/11/2024) or time (e.g., 14:30). 

 Press Enter to confirm. 

7. Entering Formulas: 

 Click on the cell where you want the result to appear. 

 Type an equals sign (=) followed by the formula (e.g., =SUM(A1:A10)). 

 Press Enter to calculate and display the result. 

8. Using AutoFill: 

 Enter data in one or more cells. 

 Select the cells you’ve just filled. 

 Drag the fill handle (a small square at the bottom-right corner of the selection) 

across the cells you want to fill. 

9. Editing Cell Content: 

 Double-click the cell you want to edit, or click on the cell and press F2. 

 Make the necessary changes. 
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 Press Enter to save the changes. 

10. Copying and Pasting Data: 

 Copy: Select the cell(s) you want to copy and press Ctrl+C (or right-click and 

select Copy). 

 Paste: Select the cell where you want to paste the data and press Ctrl+V (or 

right-click and select Paste). 

11. Deleting Cell Content: 

 Select the cell(s) you want to clear. 

 Press the Delete key. 

12. Formatting Cells: 

 Select the cell(s) you want to format. 

 Right-click and select Format Cells. 

 Choose the desired format (Number, Currency, Date, etc.) and click OK. 

Let’s Sum Up 

In Microsoft Excel, entering data and text involves selecting cells and typing directly 

into them or using the formula bar for precise input. Excel's versatility allows for easy 

manipulation and organization of data through various formatting and editing options, 

making it a powerful tool for both simple data entry and complex calculations. 

3.4 FORMATTING 

1. Font and Text Formatting: 

Bold, Italic, Underline: 

 Select the cell or range of cells. 

 Click the B, I, or U buttons in the "Home" tab. 

Font Size and Type: 

 Select the cell or range of cells. 

 Choose a font and size from the dropdown menus in the "Home" tab. 
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Font Color: 

 Select the cell or range of cells. 

 Click the Font Color button in the "Home" tab and choose a color. 

 

 

2. Cell Alignment: 

 Horizontal Alignment: 

 Select the cell(s). 

 Use the Align Left, Center, or Align Right buttons in the Home tab. 

 Vertical Alignment: 

 Select the cell(s). 

 Use the Top Align, Middle Align, or Bottom Align buttons in the Home tab. 

 Text Wrap: 

 Select the cell(s). 

 Click the Wrap Text button in the Home tab to ensure all text is visible within 

a cell. 

 Merge Cells: 

 Select the cells you want to merge. 
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 Click the Merge &Center button in the Home tab (click the arrow for more 

options like Merge Across or Merge Cells). 

 

3. Number Formatting 

 General, Number, Currency, Percentage, etc.: 

o Select the cell(s). 

o In the Home tab, use the Number Format drop-down menu to select the 

appropriate format (e.g., Number, Currency, Percentage). 

 Decimal Places: 

o After selecting a number format, you can adjust the number of decimal 

places by clicking the Increase Decimal or Decrease Decimal buttons in the 

Home tab. 

4. Cell Borders and Fill 

 Borders: 

o Select the cell(s). 

o Click the Borders button in the Home tab and choose the desired border 

style (e.g., All Borders, Outside Borders, Thick Box Border). 

 Fill Color: 

o Select the cell(s). 

o Click the Fill Color button (a paint bucket icon) in the Home tab and choose a 

color. 
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5. Conditional Formatting: 

 Select the cell(s) you want to apply conditional formatting to. 

 Go to the Home tab and click Conditional Formatting. 

 Choose a rule (e.g., Highlight Cells Rules, Top/Bottom Rules, Data Bars, Color 

Scales, Icon Sets). 

 Follow the prompts to set the conditions and format. 

6. Adjusting Column Width and Row Height: 

 AutoFit Column Width: 

o Double-click the right boundary of the column header (e.g., between A and 

B) to auto-adjust the width based on content. 

 AutoFit Row Height: 

o Double-click the bottom boundary of the row header (e.g., between 1 and 2) 

to auto-adjust the height based on content. 

 Manual Adjustment: 

o Click and drag the boundary between columns or rows to adjust width or 

height manually. 

o Right-click the column or row header and select Column Width or Row 

Height to enter a specific value. 

Let’s Sum Up 

Formatting in Microsoft Excel is crucial for organizing and presenting data 

effectively. It includes features such as cell formatting (like number, currency, and date 

formats), text formatting (like font style, size, and color), and conditional formatting for 

highlighting data based on specific criteria. These tools enable users to create clear, 

professional-looking spreadsheets that enhance readability and analysis. 

Check Your Progress 

1. What is the default file extension for an Excel workbook saved in Excel 2016 and 

later versions?  

A) .xls 

B) .xlsx 
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C) .xlsm 

D) .csv 

Answer: B) .xlsx 

2. Which of the following can you use to change the format of a cell in Excel?  

A) Home tab 

B) Data tab 

C) Insert tab 

D) View tab 

Answer: A) Home tab 

3. To merge cells in Excel, which option would you select from the Home tab?  

A) Center 

B) Merge & Center 

C) Align Right 

D) Format Cells 

Answer: B) Merge & Center 

4. Which shortcut key is used to open the Format Cells dialog box in Excel?  

A) Ctrl + F 

B) Ctrl + 1 

C) Alt + F 

D) Shift + F10 

Answer: B) Ctrl + 1 

5. In Excel, what does the "Wrap Text" feature do?  

A) It changes the text color. 

B) It allows text to appear on multiple lines within a single cell. 

C) It rotates the text in the cell. 

D) It increases the font size. 

Answer: B) It allows text to appear on multiple lines within a single cell. 

6. Which option can be used to format numbers as currency in Excel?  

A) General Format 

B) Number Format 

C) Currency Format 

D) Text Format 

Answer: C) Currency Format 
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3.5 NAVIGATING IN EXCEL 

Basic Navigation 

 Arrow Keys: Move one cell up, down, left, or right. 

 Tab: Move one cell to the right. 

 Enter: Move one cell down. 

 Ctrl + Arrow Keys: Move to the edge of data regions. 

 Home: Move to the beginning of a row. 

 Ctrl + Home: Move to the beginning of a worksheet (A1). 

 Ctrl + End: Move to the last cell with data. 

Selecting Cells 

 Shift + Arrow Keys: Select a range of cells. 

 Ctrl + Shift + Arrow Keys: Select a large range of cells in the direction of the arrow. 

 Ctrl + A: Select the entire worksheet. 

 Shift + Space: Select the entire row. 

 Ctrl + Space: Select the entire column.  

3.6 FORMULAS ENTERING HANDLING AND COPYING 

Formulas are equations that perform calculations on values in your sheet. All 

formulas begin with an equal sign (=). You can create a simple formula by using constant 

and calculation operator. For example, the formula =5+2*3, multiplies two numbers and 

then adds a number to the result. A predefined formula that simplifies entering 

calculations. 

 

1.  Equal signs start all formulas. 

2. Constants, such as numbers or text values, can be entered directly into a formula. 
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3. Operators specify the kind of calculation that the formula performs. For example, the ^ 

(caret) operator raises a number to a power, and the * (asterisk) operator multiplies 

numbers. 

4. Functions are premade formulas that can be used alone, or as part of a longer formula. 

Each function has a specific argument syntax.  

5.Cell values let you to reference an Excel cell, instead of the specific value inside the cell 

so that the contents of the cell can change without the function that refers to the cell 

having to change. 

ENTERING AND HANDLING THE FORMULA 

1. In a sheet that contains columns of numbers, click the cell where you want the formula 

results to appear. 

2. Type an equal sign = 

3. Click the first cell that you want to include in your calculation. 

 

4. Type an operator. An operator is the kind of calculation that the formula performs. For 

example, the * (asterisk) operator multiplies numbers. In this example, use the / 

(forward slash) operator to divide. At this point your formula should look like this: 

 

5. Click the next cell that you want to include in your calculation. Now your formula 

should look like this: 
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6. Press RETURN. 

The result of the calculation appears in the cell. 

 

3.6.1 COPYING A FORMULAFROM ONE EXCEL CELL TO ANOTHER 

It is easy to copy a formula from one cell to another, avoiding entering it again and 

again and saving time. We can easily copy the formula using various ways. Suppose we 

have the following Excel sheet where the values from cells A2, B2, and C2, are added in 

cell D2. We need to copy the formula from cell D2 to D3. 

 

When copying the formula from cell D2, we must first select the specific cell. We 

must press the right-click button and select the 'Copy' option to copy the entire cell 

content and the formula. Alternately, we can also use the typical keyboard shortcut 'Ctrl + 

C' to copy selected contents in Excel. 
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After copying the cell with the formula, we need to go to the cell where we must 

paste the formula (D3 in our case). Again, we need to press the right-click button and 

choose 'Formula' under the 'Paste Options' from the contextual menu (right-click menu). 

 

Alternately, we can launch Paste Special dialogue box by clicking the 'Paste 

Special' option from the contextual menu. Next, we can choose 'Formulas' under 

the 'Paste' section and click the OK button. This will paste only the formula from the 

copied cell. 
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The cell references are automatically adjusted as soon as we paste the copied 

formula into an Excel cell. However, the formula remains the same as the one in the 

copied cell. Thus, in our example, cell D3 has the same formula, but values are taken from 

cells A3, B3, and C3. The cell references are self-adjusted to match the row number or 

column of the pasted cell. 

 

 

3.6.2 COPYING A FORMULA FROM ONE EXCEL CELL TO MULTIPLE 

CELLS 

When copying a formula to multiple cells, we can follow the same steps as the 

previous method. We have to copy the cell with the formula using the "Ctrl+C" shortcut 

and then paste it on the destination cells. However, we must select all the destination cells 

before pasting the formula. To select multiple cells, we can click on the desired cells, one 
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by one, while holding down the Ctrl key. Also, we can hold down the Shift key while 

selecting multiple contiguous cells and click on the first and last cells. 

If we need to enter the formula in multiple cells, Excel also allows us to do the same 

with a single keystroke. The method works for both adjacent and non-adjacent cells. 

o First, we need to select all the cells to type the formula. We can select contiguous 

cells using the drag feature of the mouse. Besides, we can click on each non-

contiguous cell while holding the Ctrl key to select non-adjacent cells. 

 

 

o We need to press the F2 key to go to the Edit mode. 

 

o Lastly, we must enter the formula in an editing mode and press the Ctrl and Enter 

keys together (i.e., Ctrl + Enter). 
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o This will copy the entered formula into all selected cells with adjusted relative cell 

references. 

 

Let’s Sum Up 

Navigating and entering formulas in MS Excel is essential for efficient data 

manipulation and analysis. Users can navigate through worksheets using keyboard 

shortcuts or the navigation pane, while formula entry involves selecting cells, inputting 

operators and functions, and using relative or absolute cell references for calculations. 

Excel's versatility in handling complex formulas and its user-friendly interface make it a 

powerful tool for organizing and analysing data in various professional and personal 

contexts. 

Check Your Progress 

1. What symbol is used to begin a formula in Excel?   

A) @ 

B) # 

C) = 

D) & 

Answer: C) = 
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2. Which of the following formulas will correctly calculate the sum of cells A1 to 

A10?  

A) SUM(A1) 

B) A1+A10 

C) TOTAL(A1) 

D) ADD(A1) 

Answer: A) SUM(A1) 

3. What will be the result of the formula =A1/B1 if A1 contains 10 and B1 contains 0?  

A) 10 

B) 0 

C) #DIV/0! 

D) Error 

Answer: C) #DIV/0! 

4. In Excel, what is the purpose of using parentheses in a formula?  

A) To group operations 

B) To define cell references 

C) To create text strings 

D) To format numbers 

Answer: A) To group operations 

 

3.7 CHARTS 

3.7.1 CREATING A CHART 

1. To create a basic chart in Excel that you can modify and format later, 

start by entering 
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2. The data for the chart on a worksheet. It is important to include titles in 

the datasheet so that Excel can create legends and labels for the chart. 

3. Then simply select that data (including titles) and press 

F11.Thiscreatesaninstant column chart in a new tab, which can be 

customized to meet your needs. 

 

4. Or, instead of pressing F11, goto the Insert tab and select the type of 

chart you would like to create. 

5. This creates a chart embedded in the datasheet. 
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3.7.2 FORMATTING A CHART 

Once a chart has been created, there are a multitude off or matting options that can 

be applied. 

1. Select the chart. This activates the Chart Tools on the  Ribbon. 

 

2. Use the features available on the Design tab to: 

a. Change the chart type. 

b. Swap the rows and columns or adjust what data is charted. For 

example, switching the columns and rows changes the look of 

the chart, even though therawdatahasnot changed: 

c. Apply a Chart Style. 
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d. Move the chart (from the data sheet to its own tab or vice versa). 

3. Use the features available on the Layout tab to: 

a. Insert a picture, shape, or textbox. 

b. Adjust the labels, including moving the legend, editing titles, 

and adding data labels (like values). 

c. Adjust the axes and gridlines (for example, showing 

numbers on the axis in millions or adding or removing 

gridlines). 

d. Format the background. 

e. Addtrendlinestoforecastfuturedataorerrorbarstoshowpotenti

alerror amounts. 

 

4. Use the features available on the Format tab to: 

a. Apply a style, fill, outline, or effect.(For example, to change 

the color ofthe bars.) 

b. Apply and format WordArt. 

c. Use the drop down list in the Current Selection group to 

quickly adjust which area of the chart you want to format. 
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Let’s Sum Up 

Creating charts in Microsoft Excel allows for the visual representation of data, 

making it easier to understand and analyze trends and patterns. Excel offers various chart 

types, such as bar, line, pie, and scatter plots, which can be customized to suit specific 

data presentation needs. 

 



CDOE - ODL B.SC (COMPUTER SCIENCE) – SEMESTER IV UNIT - III 

 

90 Periyar University – CDOE| Self-Learning Material 

 

Check Your Progress 

1. Which of the following chart types is best used to show the relationship between 

two variables? 

A) Pie Chart 

B) Line Chart 

C) Scatter Plot 

D) Column Chart 

Answer: C) Scatter Plot 

2. What is the main purpose of a Pie Chart in MS Excel? 

A) To display trends over time 

B) To compare the frequency of categories 

C) To show the proportion of parts to a whole 

D) To illustrate the relationship between different datasets 

Answer: C) To show the proportion of parts to a whole 

3. Which chart type would you use to compare the performance of multiple 

categories over time? 

A) Doughnut Chart 

B) Bar Chart 

C) Area Chart 

D) Stacked Column Chart 

Answer: D) Stacked Column Chart 

4. What feature in MS Excel allows you to quickly change the data range of a chart? 

A) Chart Filters 

B) Chart Styles 

C) Chart Elements 

D) Chart Data Selector 

Answer: A) Chart Filters 

5. In MS Excel, which of the following can be used to add a trendline to a chart? 

A) Data Labels 

B) Axis Titles 

C) Chart Tools 

D) Format Data Series 
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Answer: D) Format Data Series 

3.8 PREPARATION OF FINANCIAL STATEMENT 

Creating financial statements in MS Excel involves using various functions and 

formatting tools to organize and calculate financial data effectively. Here’s a step-by-step 

guide to help you get started: 

Step 1: Set Up Your Workbook 

1. Open Excel: Start Excel and create a new workbook. 

2. Worksheet Setup: Rename your worksheets. Typically, you might have sheets for 

Income Statement, Balance Sheet, and Cash Flow Statement. 

Step 2: Enter Your Data 

1. Income Statement: 

o Enter revenue and expenses data. Label columns for items like Sales, Cost 

of Goods Sold, Operating Expenses, etc. 

o Calculate subtotal for Gross Profit and Operating Income. 

2. Balance Sheet: 

o Enter assets (current and non-current) and liabilities (current and long-term). 

o Include equity items such as Retained Earnings and Common Stock. 

o Calculate totals for Assets and Liabilities + Equity. 

3. Cash Flow Statement: 

o List operating, investing, and financing activities. 

o Calculate Net Cash Flow from Operations, Investing Activities, and Financing 

Activities. 

Step 3: Use Formulas and Functions 

 Basic Formulas: 

o Use basic arithmetic operations (+, -, *, /) for calculations. 

o Example: =SUM(B2:B10) to sum up a range of cells. 

 Financial Functions: 
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o Utilize functions like SUM, SUMIF, SUMIFS, AVERAGE, IF, VLOOKUP, etc., 

as per your requirements. 

o Example: =SUMIF(B2:B10, ">1000") to sum values greater than 1000. 

 Excel Tables: 

o Convert your data range into a table (Ctrl + T), which allows easy referencing 

and automatic formula application as you add more data. 

Step 4: Formatting 

 Currency Formatting: 

o Select cells and apply appropriate currency formatting (Ctrl + Shift + $). 

 Alignment and Styling: 

o Format headings, numbers, and dates for clarity and consistency. 

o Use bold, italics, and underline for emphasis where needed. 

Step 5: Review and Finalize 

 Check Formulas: 

o Double-check all formulas and calculations to ensure accuracy. 

 Graphs and Charts: 

o Create charts (e.g., pie charts, line graphs) to visualize financial data. 

o Use Insert > Charts and select the appropriate chart type. 

Step 6: Save and Share 

 Save Your Workbook: 

o Save your Excel file (Ctrl + S) regularly to avoid losing your work. 

 Share Your Workbook: 

o Share your final workbook with colleagues or stakeholders as needed. 

Let’s Sum Up 

Preparing a financial statement in MS Excel involves organizing financial data into a 

structured format, typically using spreadsheets to create income statements, balance 

sheets, and cash flow statements. This process includes inputting relevant financial data, 
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applying formulas for calculations, and using built-in functions and tools to ensure 

accuracy and clarity in the presentation of financial information. 

3.9 INTRODUCTION TO DATA ANALYTICS 

A Table is a rectangular range of structured data. The key features are − 

 Each row in the table corresponds to a single record of the data. Example - 

Employee information. 

 Each column contains a specific piece of information. Exmaple - The columns can 

contain data such as name, employee number, hire date, salary, department, etc. 

 The top row describes the information contained in each column and is referred to 

as header row. 

 Each entry in the top row is referred to as column header. 

 

3.9.1 CREATE TABLE 

To create a table from the data you have on the worksheet, follow the given steps − 

Step 1 − Select the Range of Cells that you want to include in the Table. Cells can contain 

data or can be empty. The following Range has 290 rows of employee data. The top row 

of the data has headers. 
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Step 2 − Under the Insert tab, in the Tables group, click Tables. The Create Table dialog 

box appears. Check that the data range selected in the Where is the data for your 

table? Box is correct. 

 

Step 3 − Check the My table has headers box if the top row of the selected Range 

contains data that you want to use as the Table Headers. 
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Note − If you do not check this box, your table will have Headers – Column1, Column2, 

Step 4 − Click OK. 

 

Range is converted to Table with the default Style. 

 

Step 5 − You can also convert a range to a table by clicking anywhere on the range and 

pressing Ctrl+T. A Create Table dialog box appears and then you can repeat the steps as 

given above. 
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3.9.2 TABLE HEADERS REPLACING COLUMN LETTERS 

In the worksheet given below, the column letters are appearing as they are and the 

table headers are in row 2. 21 rows of 290 rows of data are visible. 

 

Scroll down to see the table rows 25 – 35. The table headers will replace the 

column letters for the table columns. Other column letters remain as they are. 
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3.9.3 PROPAGATION OF A FORMULA IN A TABLE LETTERS 

In the table given below, suppose you want to include the age of each employee. 

Step 1 − Insert a column to the right of the column Birthdate. Type Age in the Column 

Header. 

Step 2 − In any of the Cells in that empty column, type the Formula, =DAYS 

([@BirthDate], TODAY ()) and Press Enter. 

 

The formula propagates automatically to the other cells in that column of the table. 
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3.9.4 REMOVE DUPLICATES 

When you gather data from different sources, you probably can have duplicate values. 

You need to remove the duplicate values before going further with analysis. 

Look at the following data where you have information about various products of various 

brands. Suppose, you want to remove duplicates from this data. 
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 Click the table. 

 On the DESIGN tab, click Remove Duplicates in the Tools group on the Ribbon. 

The Remove Duplicates dialog box appears. 

 

The column headers appear under columns in the Remove Duplicates dialog box. 

 Check the column headers depending on which column you want to remove the 

duplicates and click OK. 

You will get a message on how many rows with duplicate values are removed and how 

many unique values remain. The cleaned data will be displayed in the table. 
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Remove duplicates with Remove Duplicates in the Data Tools group under DATA 

tab on the Ribbon. 

Let’s Sum Up 

Data analytics in MS Excel involves using tools like pivot tables, charts, and various 

functions to analyze and visualize data. Excel's features allow users to perform complex 

calculations, identify trends, and gain insights from large datasets efficiently. 

3.10 Unit Summary 

 This unit covers the creation and formatting of charts to visually represent data, as well 

as the preparation of analysis tables for summarizing and analyzing large datasets. 

 This unit also introduces learners to the basics of data analytics in Excel, providing 

them with foundational knowledge of data manipulation, visualization, and basic 

statistical analysis techniques. 

3.11 Glossary  

 Cell  - The intersection of a row and column. 

 Formula - An expression to calculate values. 

 Function - Predefined calculation, e.g., SUM. 

 Workbook - A file containing one or more sheets. 

 Worksheet - A single spreadsheet within a workbook. 

 Range  - A selection of two or more cells. 

 Chart  - A visual representation of data 

3.12 Self-Assessment Questions  

1. How do you open an existing Excel spreadsheet? 

2. What are three methods for entering text and data into Excel cells? 

3. What is a formula in Excel, and how do you enter one into a cell? 

4. Describe a situation where you might use the SUM function in Excel. 

5. What is a chart in Excel, and how can it help visualize data? 

6. Name two types of charts you can create in Excel and briefly describe each 

one. 
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3.13 Activity:  

Activity 1: Create a Student Attendance Sheet 

 Steps: 

o Open a new Excel workbook. 

o In Sheet1, create a table with columns for "Date," "Student Name," "Roll 

Number," and "Attendance Status (Present/Absent)". 

o Enter sample data for 10 students over 5 days. 

o Format the headers with bold and a background color. 

o Use "Freeze Panes" to keep headers visible while scrolling. 

Activity 2: Employee Details Record 

 Steps: 

o Create a table with columns such as "Employee ID," "Name," "Department," 

"Designation," "Salary". 

o Enter data for at least 5 employees. 

o Format the text to be centered, and apply conditional formatting to highlight 

any salaries above a certain threshold (e.g., $5000). 

 

3.14 References and Suggested Readings  

1. Peter Norton, Introduction to Computers–Tata McGraw-Hill. 

2. Jennifer Ackerman Kettel, Guy Hat-Davis, Curt Simmons, ―Microsoft 2003, 

Tata McGrawHill 

3. TorbenLageFrandsen, Microsoft Office Excel, 2007 

 

 

*************************************** 

UNIT - III COMPLETED

https://www.google.co.in/search?sca_esv=9d633321853007a8&sca_upv=1&hl=en&sxsrf=ADLYWIKG24VUraPlueht2NkC8JVz6h-rOg:1717756160893&q=inauthor:%22Torben+Lage+Frandsen%22&tbm=bks


CDOE - ODL B.SC (COMPUTER SCIENCE) – SEMESTER IV UNIT - IV 

 

102 Periyar University – CDOE| Self-Learning Material 

 

UNIT – IV 

DATABASE CONCEPTS 

 

UNIT IV -    DATABASE CONCEPTS 

Database Concepts: The concept of data base management system; Data field, 

records, and files, Sorting and indexing data; Searching records. Designing queries, 

and reports; Linking of datafiles; Understanding Programming environment in 

DBMS; Developing menu drive applications in query language (MS–Access). 
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4.1.2 Advantages of DBMS 104 

4.1.3 Disadvantages of DBMS 105 
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4.3 Sorting and Indexing Data 109 
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4.3.2 Indexing Data 110 
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4.4.1 Steps For Searching Records In A DBMS 111 
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4.5.3 Tools For Designing Queries And Reports 114 
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4.6 Linking Data Files 114 

4.6.1 Key Concepts 115 
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4.7.1 Hardware 120 
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4.7.3 Data 120 
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Access) 
122 
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4.8.3 Create Forms 123 

4.8.4 Create Macros For Common Tasks 124 

4.8.5 Test The Application 124 

4.9 Unit- Summary 126 

4.10 Glossary 126 
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4.12 Activities / Exercises / Case Studies 127 

4.13 References  and Suggested Readings 128 

UNIT OBJECTIVES 

 In this unit aims to provide a comprehensive introduction to the Database 

Concepts.  

 Learners will be able to understand the concepts of data filed, records, sorting 

and filtering techniques.  

 Furthermore, this unit covers the concepts of indexing, Query and Reports. 
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4.1 THE CONCEPT OF DBMS 

A Database Management System (DBMS) is a software system that is designed to 

manage and organize data in a structured manner. It allows users to create, modify, and 

query a database, as well as manage the security and access controls for that database.  

4.1.1 KEY FEATURES OF DBMS 

Data modelling: A DBMS provides tools for creating and modifying data models, which 

define the structure and relationships of the data in a database. 

Data storage and retrieval: A DBMS is responsible for storing and retrieving data from 

the database, and can provide various methods for searching and querying the data. 

Concurrency control: A DBMS provides mechanisms for controlling concurrent access to 

the database, to ensure that multiple users can access the data without conflicting with 

each other. 

Data integrity and security: A DBMS provides tools for enforcing data integrity and 

security constraints, such as constraints on the values of data and access controls that 

restrict who can access the data. 

Backup and recovery: A DBMS provides mechanisms for backing up and recovering the 

data in the event of a system failure. 

DBMS can be classified into two types: Relational Database Management System 

(RDBMS) and Non-Relational Database Management System (NoSQL or Non-SQL).  

RDBMS: Data is organized in the form of tables and each table has a set of rows and 

columns. The data are related to each other through primary and foreign keys. 

NoSQL: Data is organized in the form of key-value pairs, documents, graphs, or column-

based. These are designed to handle large-scale, high-performance scenarios. 

 

4.1.2 ADVANTAGES OF DBMS 

Data organization: A DBMS allows for the organization and storage of data in a 

structured manner, making it easy to retrieve and query the data as needed. 

Data integrity: A DBMS provides mechanisms for enforcing data integrity constraints, 

such as constraints on the values of data and access controls that restrict who can access 

the data. 
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Concurrent access: A DBMS provides mechanisms for controlling concurrent access to 

the database, to ensure that multiple users can access the data without conflicting with 

each other. 

Data security: A DBMS provides tools for managing the security of the data, such as 

controlling access to the data and encrypting sensitive data. 

Backup and recovery: A DBMS provides mechanisms for backing up and recovering the 

data in the event of a system failure. 

Data sharing: A DBMS allows multiple users to access and share the same data, which 

can be useful in a collaborative work environment. 

4.1.3 DISADVANTAGES OF DBMS 

Complexity: DBMS can be complex to set up and maintain, requiring specialized 

knowledge and skills. 

Performance overhead: The use of a DBMS can add overhead to the performance of an 

application, especially in cases where high levels of concurrency are required. 

Scalability: The use of a DBMS can limit the scalability of an application, since it requires 

the use of locking and other synchronization mechanisms to ensure data consistency. 

Cost: The cost of purchasing, maintaining and upgrading a DBMS can be high, especially 

for large or complex systems. 

 

Let’s Sum Up 

A Database Management System (DBMS) is software that facilitates the creation, 

management, and manipulation of databases, enabling efficient data storage, retrieval, 

and updating. It ensures data integrity, security, and consistency while providing a 

systematic way to manage large amounts of structured information. 

4.2 DATA FIELD, RECORDS, AND FILES 

Data Field 

 A data field is the smallest unit of information in a database. It represents an 

attribute or characteristic of an entity. For example, in a database of students, fields 

could include "Student ID," "Name," "Age," "Gender," etc. 
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 Each data field has a defined data type (such as text, numeric, date, etc.) and 

constraints (such as maximum length, format, etc.). 

Records 

 A record, also known as a tuple or row, is a collection of related data fields that 

represent a single entity or occurrence within a database. 

 For example, in a database of employees, a record could contain information such 

as employee ID, name, department, position, and salary. 

 Records are organized and stored together based on a unique identifier, such as a 

primary key, which distinguishes one record from another. 

Files 

 A file, also referred to as a table, is a collection of records that share a common 

structure and are grouped together for efficient storage and retrieval. 

 In a relational database, files are often referred to as tables, where each table 

represents a specific entity or concept. 

 For instance, in a university database, there could be separate files or tables for 

students, courses, instructors, etc. 

 Each file/table consists of rows (records) and columns (data fields), with each 

column representing a specific attribute of the entity. 

Example: Let's consider a simple example of a database for a library: 

Data Fields: 

 Book ID (numeric) 

 Title (text) 

 Author (text) 

 Genre (text) 

 Publication Year (numeric) 

 ISBN (text) 
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Records (Rows): 

 Record 1: 

o Book ID: 101 

o Title: "To Kill a Mockingbird" 

o Author: Harper Lee 

o Genre: Fiction 

o Publication Year: 1960 

o ISBN: 978-0061120084 

 Record 2: 

o Book ID: 102 

o Title: " A Programming Guide " 

o Author: George Orwell 

o Genre: Dystopian Fiction 

o Publication Year: 1949 

o ISBN: 978-0451524935 

File (Table): 

 Library Catalog: 

Book 

ID 
Title Author Genre 

Publication 

Year 
ISBN 

101 
To Kill a 

Mockingbird 
Harper Lee Fiction 1960 

978-

0061120084 

102 
A Programming 

Guide 

George 

Orwell 

Dystopian 

Fiction 
1949 

978-

0451524935 

 

In this example, "Library Catalog" is a file/table containing records of books. Each record 

represents a specific book, and each data field within the record provides information 

about that book. 
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Let’s Sum Up 

Data files and records in a Database Management System (DBMS) are organized 

collections of data stored and accessed electronically. DBMSs ensure efficient data 

management, retrieval, and manipulation, supporting various applications by providing a 

systematic way to handle large volumes of data accurately and securely. 

Check Your Progress 

1. Which of the following is NOT a characteristic of a Database Management System 

(DBMS)? 

A) Data Redundancy 

B) Data Integrity 

C) Data Isolation 

D) Data Inconsistency 

Answer: D) Data Inconsistency 

2. Which component of DBMS is responsible for managing data storage, retrieval, and 

updates? 

A) Query Processor 

B) Database Engine 

C) Transaction Manager 

D) Data Dictionary 

Answer: B) Database Engine 

3. Which of the following is an example of a Relational Database Management System 

(RDBMS)? 

A) MongoDB 

B) Neo4j 

C) Oracle 

D) Hadoop 

Answer: C) Oracle 

4. Which SQL statement is used to delete a table from a database? 

A) DROP TABLE 

B) DELETE TABLE 

C) REMOVE TABLE 

D) ERASE TABLE 
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Answer: A) DROP TABLE 

5. In a relational database, which key uniquely identifies each record in a table? 

A) Foreign Key 

B) Candidate Key 

C) Primary Key 

D) Super Key 

Answer: C) Primary Key 

 

4.3 SORTING AND INDEXING DATA 

4.3.1 SORTING DATA 

Sorting data in a DBMS involves arranging the records in a specific order based on the 

values of one or more fields. Sorting makes it easier to retrieve and analyze data in a 

meaningful way. Consider the same example of a librarycatalog with the following table 

structure: 

LibraryCatalog: 

Book 
ID 

Title Author Genre 
Publication 
Year 

ISBN 

101 
To Kill a 
Mockingbird 

Harper Lee Fiction 1960 
978-
0061120084 

102 
A Programming 
Guide 

George Orwell 
Dystopian 
Fiction 

1949 
978-
0451524935 

103 The Great Gatsby 
F. Scott 
Fitzgerald 

Classic 1925 
978-
0743273565 

104 Moby Dick 
Herman 
Melville 

Adventure 1851 
978-
1503280786 

To sort the table by the Title in ascending order: 

Book 
ID 

Title Author Genre 
Publication 
Year 

ISBN 

102 
A Programming 
Guide 

George Orwell 
Dystopian 
Fiction 

1949 
978-
0451524935 
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Book 
ID 

Title Author Genre 
Publication 
Year 

ISBN 

103 The Great Gatsby 
F. Scott 
Fitzgerald 

Classic 1925 
978-
0743273565 

104 Moby Dick 
Herman 
Melville 

Adventure 1851 
978-
1503280786 

101 
To Kill a 
Mockingbird 

Harper Lee Fiction 1960 
978-
0061120084 

To sort the table by Publication Year in descending order: 

Book 
ID 

Title Author Genre 
Publication 
Year 

ISBN 

101 
To Kill a 
Mockingbird 

Harper Lee Fiction 1960 
978-
0061120084 

102 
A Programming 
Guide 

George Orwell 
Dystopian 
Fiction 

1949 
978-
0451524935 

103 The Great Gatsby 
F. Scott 
Fitzgerald 

Classic 1925 
978-
0743273565 

104 Moby Dick 
Herman 
Melville 

Adventure 1851 
978-
1503280786 

4.3.2 INDEXING DATA 

Indexing in a DBMS involves creating a separate data structure (index) that contains 

pointers to the actual locations of records in a database file. Indexing helps speed up data 

retrieval operations, especially for large databases, by allowing the DBMS to quickly locate 

records without having to search through every record sequentially. 

Benefits of Indexing: 

 Faster Searches: When you search for a book by its title, the database can use the 

index to quickly locate the records. 

 Efficient Sorting: Indexes can also speed up sorting operations on indexed 

columns. 
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Drawbacks of Indexing: 

 Storage Overhead: Indexes consume additional disk space. 

 Maintenance Overhead: Indexes need to be updated whenever records are 

inserted, updated, or deleted, which can slow down these operations. 

Using the same library database example, let's create an index on the "Title" field: 

Book ID Title 

101 To Kill a Mockingbird 

102 A Programming Guide 

103 The Great Gatsby 

104 Moby Dick 

In the index, each unique title value is associated with the corresponding Book ID. Now, if 

we want to retrieve the record for the book "To Kill a Mockingbird," the DBMS can use the 

index to quickly locate the record without having to scan through the entire database file. 

4.4 SEARCHING RECORDS 

Searching for records in a DBMS involves querying the database to retrieve specific data 

based on certain criteria. In the context of our "LibraryCatalog" example, we can use SQL 

(Structured Query Language) to search for records. 

4.4.1 STEPS FOR SEARCHING RECORDS IN A DBMS 

1. Identify the Table: 

 In our example, the table is LibraryCatalog. 

2. Define the Criteria: 

 Criteria are the conditions that the records must meet to be retrieved. For example, 

you might want to find books by a specific author, books published in a certain year, 

or books of a certain genre. 
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3. Write the Query: 

 Use SQL to write a query that specifies the table and criteria. 

Examples of Searching Records 

Using the sample data from our "LibraryCatalog" table: 

Book 
ID 

Title Author Genre 
Publication 

Year 
ISBN 

101 
To Kill a 
Mockingbird 

Harper Lee Fiction 1960 
978-
0061120084 

102 
A Programming 
Guide 

George 
Orwell 

Dystopian 
Fiction 

1949 
978-
0451524935 

 

Search for Books by a Specific Author: 

Suppose we want to find all books by "Harper Lee." 

SELECT * FROM LibraryCatalog WHERE Author ='Harper Lee'; 

Book ID Title Author Genre Publication Year ISBN 

101 To Kill a Mockingbird Harper Lee Fiction 1960 978-0061120084 

Search for Books Published in a Specific Year: 

Suppose we want to find all books published in the year 1949. 

SELECT*FROM Library Catalog WHERE Publication Year=1949; 

 

Book 
ID 

Title Author Genre 
Publication 

Year 
ISBN 

102 
A Programming 
Guide 

George 
Orwell 

Dystopian 
Fiction 

1949 
978-
0451524935 
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Let’s Sum Up 

Sorting and indexing in DBMS are crucial for optimizing query performance and 

data retrieval. Sorting organizes data in a specified order, while indexing creates data 

structures that improve the speed of search operations by allowing quick access to rows in 

a database. Together, they enhance efficiency and ensure faster query processing. 

4.5 DESIGNING QUERIES, AND REPORTS 

4.5.1 DESIGNING QUERIES 

Queries are requests to retrieve data from a database. They are written using SQL 

(Structured Query Language) to specify what data to fetch and how to display it. Below are 

some examples of designing queries for the "LibraryCatalog" table. 

1. Simple Queries 

To fetch all records from the "LibraryCatalog" table: 

SELECT * FROM LibraryCatalog; 

2. Conditional Queries 

To find all books by "Harper Lee": 

SELECT * FROM LibraryCatalog WHERE Author ='Harper Lee'; 

3. Aggregate Queries 

To count the total number of books in the catalog: 

SELECT COUNT (*) FROM Library Catalog; 

4.5.2 DESIGNING REPORTS 

Reports are structured presentations of data, often generated from the results of queries. 

They can be used for data analysis, decision-making, and communication of information. 

Below are examples of designing reports based on the "Library Catalog" table. 
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Detailed Report 

A detailed report can list all books along with their details, sorted by publication year. 

SQL Query: 

SELECT * FROM Library Catalog ORDER BY Publication Year DESC; 

Report Format: 

Book 
ID 

Title Author Genre 
Publication 

Year 
ISBN 

101 
To Kill a 
Mockingbird 

Harper Lee Fiction 1960 
978-
0061120084 

102 
A Programming 
Guide 

George 
Orwell 

Dystopian 
Fiction 

1949 
978-
0451524935 

 

4.5.3 Tools for Designing Queries and Reports 

Various tools and software can be used for designing and executing queries, and for 

generating reports: 

 SQL Clients: Tools like MySQL Workbench, Microsoft SQL Server Management 

Studio (SSMS), and pgAdmin. 

 Reporting Tools: Tools like Crystal Reports, Microsoft Power BI, Tableau, and 

Jasper Reports. 

These tools help users to visually design queries, execute them, and generate formatted 

reports that can be used for further analysis and presentation. 

4.6 LINKING DATA FILES 

Linking data files in a database management system (DBMS) is a fundamental concept 

that ensures data integrity and efficient data retrieval. This process typically involves the 

use of primary keys, foreign keys, and various types of relationships between tables. 
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Here’s an explanation of linking data files using our "Library Catalog" example, extended 

to include additional related tables. 

4.6.1 KEY CONCEPTS 

1. Tables: 

o Tables are the fundamental objects in a database that store data in rows and 

columns. 

o Each table typically represents an entity (e.g., customers, orders, products). 

2. Primary Key: 

o A primary key is a unique identifier for each record in a table. 

o It ensures that each row can be uniquely identified. 

o Example: In a Customers table, CustomerID could be a primary key. 

3. Foreign Key: 

o A foreign key is a column or a set of columns in one table that uniquely 

identifies a row in another table. 

o It establishes a link between the data in two tables. 

o Example: In an Orders table, CustomerID can be a foreign key that links to 

CustomerID in the Customers table. 

4. Relationships: 

o One-to-One: Each row in Table A is linked to one and only one row in Table 

B. 

o One-to-Many: A row in Table A can be linked to multiple rows in Table B. 

o Many-to-Many: Rows in Table A can be linked to multiple rows in Table B, 

and vice versa (typically implemented using a junction table). 

 

Example of Linking Data files 

Consider an example with three tables: Customers, Orders, and OrderDetails. 

1. Customers Table: 

o Columns: CustomerID (Primary Key), CustomerName, ContactInfo 

2. Orders Table: 

o Columns: OrderID (Primary Key), OrderDate, CustomerID (Foreign Key) 
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3. Order Details Table: 

o Columns: OrderDetailID (Primary Key), OrderID (Foreign Key), ProductID, 

Quantity 

4.6.2 CREATING RELATIONSHIPS 

1. Creating Tables: 

 

2. Inserting Data: 
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4.6.3 ENSURING DATA INTEGRITY 

Referential Integrity: 

 Ensured by foreign keys, which make sure that a row in a child table cannot 

reference a non-existent row in the parent table. 

. 

Constraints: 

 Enforced by the DBMS to maintain accuracy and reliability of the data within the 

database. 

 Example constraints include NOT NULL, UNIQUE, CHECK, and DEFAULT. 

Let’s Sum Up 

Designing queries and reports in a DBMS involves formulating precise SQL 

statements to retrieve and manipulate data according to specific requirements. This 

process includes selecting relevant tables, defining criteria for data extraction, and 

formatting the output to generate insightful and actionable reports. 

Check Your Progress 

1. Which SQL command is used to retrieve data from a database? 

A) INSERT 

B) SELECT 

C) UPDATE 

D) DELETE 

Answer: B) SELECT 

2. When designing a report, which element is typically used to group data? 

A) Footer 

B) Header 

C) Grouping Level 

D) Summary 

Answer: C) Grouping Level 
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3. In a database query, what does the "WHERE" clause do? 

A) Specifies which fields to return 

B) Limits the results based on a condition 

C) Joins two tables together 

D) Orders the results 

Answer: B) Limits the results based on a condition 

4. What is the purpose of using parameters in queries? 

A) To increase the speed of the query 

B) To filter the data dynamically at runtime 

C) To create a static report 

D) To ensure all records are retrieved 

Answer: B) To filter the data dynamically at runtime 

5. In report design, which format is typically used for presenting numeric data 

clearly? 

A) Plain text 

B) Tabular format 

C) Paragraph format 

D) Image format 

Answer: B) Tabular format 

 

4.7 UNDERSTANDING PROGRAMMING ENVIRONMENT IN 

DBMS 

The database system consists of many components. Each component performing very 

significant tasks in the database management system environment. A database 

environment is a collective system of components that comprise and regulates the group of 

data, management, and use of data, which consist of software, hardware, people, 

techniques of handling database, and the data also. 
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Database System Environment 

The hardware in a database environment means the computers and computer peripherals 

that are being used to manage a database, and the software means the whole thing right 

from the operating system (OS) to the application programs that include database 

management software like M.S. Access or SQL Server. Again the people in a database 

environment include those people who administrate and use the system. The techniques 

are the rules, concepts, and instructions given to both the people and the software along 

with the data with the group of facts and information positioned within the database 

environment. The database management system can be divided into five major 

components such as Hardware, Software, Data, Procedures, and People. 
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4.7.1 HARDWARE 

 When we say hardware, we mean computer, hard disk, I/o channels for data and any 

other physical components involved before any data is successfully stored into the 

memory. 

 This provides the interface between computers and the real world system. 

4.7.2 SOFTWARE 

 This is the set of programs used to control and manage the overall database. This 

includes the DBMS software itself, the operating system, the network software being 

used to share the data among users, and the application program used to access data 

in the DBMS. 

 This is the main component, as this the program which controls everything. The DBMS 

software is more like a wrapper around the physical database, which provides us with 

an easy-to-use interface to store, access and update data. 

4.7.3 DATA 

 The main task of DBMS is to process the data. Here database are defined, constructed, 

and then data is stored, retrieved, and updated to and form the database. 
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 It is the most important component of the database management system. The database 

contains both the metadata(data about data) and the actual(operational) data. 

4.7.4 PROCEDURES 

 These are the instructions and rules that assist on how to use the DBMS, and in 

designing and running the database, using documented procedures, to guide the users 

that operate and manage it. 

 Procedures are used to setup and install a new DBMS to login and logout of DBMS 

software, to manage DBMS or application programs, to take backup of the database, 

and to change the structure of the database, etc. 

4.7.5 PEOPLE 

 The people are who control and manage the databases and perform different types of 

operations on the database in the DBMS. The people include database administrator, 

software developer and End user. 

 Database administrator-database administrator is the one who manages the complete 

database management system. DBA takes care of the security of the DBMS, it’s 

availability, managing the license keys, managing user accounts and access, etc. 

 Software developer-This user group is involved in developing and designing the parts of 

DBMs. 

 End user- These days all the modern applications, web or mobile, store user data.  

 

Let’s Sum Up 

A programming environment in a Database Management System (DBMS) provides 

tools and interfaces for database creation, manipulation, and management, typically 

through SQL (Structured Query Language). It often includes features like query editors, 

debugging tools, and support for stored procedures and triggers, facilitating efficient and 

effective database development and maintenance. 
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4.8 DEVELOPING MENU DRIVE APPLICATIONS IN QUERY 

LANGUAGE (MS–ACCESS) 

Developing menu-driven applications in MS Access involves creating a user-friendly 

interface that allows users to navigate and perform database operations without needing to 

write SQL queries directly. This typically includes using forms, buttons, and macros. Below 

is a step-by-step guide on how to create a menu-driven application in MS Access using the 

example of a "LibraryCatalog" database. 

4.8.1 CREATE THE DATABASE AND TABLES 

1. Create a New Database: 

o Open MS Access. 

o Select "File" > "New" > "Blank Database." 

o Save the database with an appropriate name, e.g., LibraryCatalog.accdb. 

2. Create Tables: 

o Authors Table: 

 

o LibraryCatalog Table: 

 



CDOE - ODL B.SC (COMPUTER SCIENCE) – SEMESTER IV UNIT - IV 

 

123 Periyar University – CDOE| Self-Learning Material 

 

4.8.2 DEFINE RELATIONSHIPS 

1. Open Relationships Window: 

o Go to "Database Tools" > "Relationships." 

2. Add Tables: 

o Add the Authors, and LibraryCatalog, tables to the Relationships window. 

3. Create Relationships: 

o Drag AuthorID from Authors to AuthorID in LibraryCatalog (One-to-Many). 

4.8.3 CREATE FORMS 

1. Create a Main Menu Form: 

o Go to "Create" > "Form Design." 

o Add buttons for different operations, such as "Add Book," "View Books," "Add 

Borrower," "View Borrowers," "Borrow Book," and "Return Book." 

o Use the "Button" tool in the Design tab to create buttons and assign appropriate 

labels and actions. 

2. Create Sub-Forms: 

o For each operation (e.g., adding a book), create separate forms: 

 Add Book Form: 

 Use "Create" > "Form Design." 

 Add text boxes for entering Title, AuthorID, Genre, 

PublicationYear, and ISBN. 

 Add a "Save" button that saves the new record to LibraryCatalog. 

 View Books Form: 

 Use "Create" > "Form Wizard." 

 Select the LibraryCatalog table and choose the fields to display. 

 Complete the wizard to create a form that lists all books. 

 Repeat similar steps to create forms for adding borrowers, viewing 

borrowers, borrowing books, and returning books. 

 

 



CDOE - ODL B.SC (COMPUTER SCIENCE) – SEMESTER IV UNIT - IV 

 

124 Periyar University – CDOE| Self-Learning Material 

 

4.8.4 CREATE MACROS FOR COMMON TASKS 

1. Open Form Macro: 

o Create a macro to open specific forms. For instance, create a macro named 

OpenAddBookForm: 

 Action: OpenForm 

 Form Name: AddBookForm 

2. Save Record Macro: 

o Create a macro to save a record in forms where data is entered: 

 Action: RunCommand 

 Command: SaveRecord 

3. Assign Macros to Buttons: 

o In the form design view, assign the appropriate macros to the "On Click" event 

of buttons. 

4.8.5 TEST THE APPLICATION 

1. Open Main Menu Form: 

o Set the Main Menu form to open automatically on database startup: File > 

Options > Current Database > Display Form > Select "Main Menu Form." 

o  

2. Test Each Function: 

o Test each button on the Main Menu to ensure it opens the correct form and 

performs the desired operations. 

Let’s Sum Up 

Developing a menu-driven application in MS Access involves creating a user-

friendly interface that allows users to navigate through various forms, reports, and queries 

using custom menus. This can be achieved by designing switchboards or utilizing the 

Ribbon interface, ensuring an intuitive experience for efficient data management and 

interaction. 
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Check Your Progress 

1. What is the primary purpose of a menu-driven application in MS Access?  

A) To store data 

B) To provide a user interface for executing queries 

C) To create forms 

D) To generate reports 

Answer: B) To provide a user interface for executing queries 

2. Which of the following is a common method to create a menu in MS Access?  

A) Using Excel 

B) Creating a Macro 

C) Writing VBA code 

D) Both B and C 

Answer: D) Both B and C 

3. In MS Access, which of the following query types is used to retrieve data based 

on user input from a menu?  

A) Action Query 

B) Select Query 

C) Parameter Query 

D) Delete Query 

Answer: C) Parameter Query 

4. To add a button to a form in MS Access that executes a specific query, which of 

the following properties must be set?  

A) Control Source 

B) On Click 

C) Data Source 

D) Default Value 

Answer: B) On Click 

5. What is the result of using the "MsgBox" function in a menu-driven application in 

MS Access?  

A) It saves data to the database. 

B) It displays a message box to the user. 
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C) It executes a SQL query. 

D) It creates a new table. 

Answer: B) It displays a message box to the user. 

 

4.9 Unit Summary  

 Sorting and indexing operations are fundamental for organizing data and improving 

retrieval efficiency, facilitating quick access to relevant information.  

 Searching records involves querying the database based on specified criteria, 

utilizing indexing and search algorithms to locate desired data.  

 Linking data files establishes relationships between datasets, ensuring data integrity 

and coherence across the database.  

 Demonstrate proficiency in searching records within a database, utilizing search 

algorithms and indexing techniques to locate specific information. 

 Understanding the programming environment within a DBMS is explored, with a 

focus on developing menu-driven applications in query languages like MS-Access.  

4.10 Glossary  

 Database  - An organized collection of data. 

 DBMS  - Software for managing databases. 

 SQL  - Language for querying databases. 

 Primary Key - Unique identifier for records. 

 Foreign Key - A key linking two tables. 

 Normalization - Process of organizing data to reduce redundancy. 

 Index  - A performance optimization feature. 

4.11 Self-Assessment Questions 

1. What is a database management system (DBMS), and what is its primary 

function? 

2. Explain the purpose of sorting and indexing data in a database. How do these 

operations improve data retrieval? 

3. What is a query in the context of databases? How do you design and execute 

queries to retrieve specific information from a database? 
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4. Discuss the importance of reports in a database system. What types of 

information can be included in a database report? 

5. Explain the concept of linking data files in a database. When and why would 

you link multiple data files together? 

6. Describe the process of developing menu-driven applications in query 

language, using MS Access as an example. 

 

4.12 Case Study: Library Management System 

Objective: To design and implement a database management system for managing a 

small library using MS Access. 

Tasks: 

1. Database Concepts & Design: 

o Create tables to store information about books (BookID, Title, Author, Genre, 

YearPublished), members (MemberID, Name, ContactInfo, 

MembershipDate), and borrowing records (TransactionID, MemberID, 

BookID, BorrowDate, ReturnDate). 

2. Data Field, Records, and Files: 

o Define the fields for each table, making sure to set appropriate data types 

and constraints. 

o Populate the tables with sample data. 

3. Sorting and Indexing Data: 

o Create an index on the BookID and MemberID fields to optimize search 

queries. 

o Sort the list of books based on the YearPublished field and generate a 

report. 

4. Searching Records: 

o Implement queries to search for: 

 Books by a specific author. 

 Books borrowed by a particular member. 

 Overdue books based on the current date. 

5. Designing Queries and Reports: 

o Create queries to generate: 
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 A list of all books currently borrowed along with member details. 

 A report of all new members who joined in the past month. 

 A summary report of the total number of books in each genre. 

6. Linking of Data Files: 

o If the library data is split into multiple files, demonstrate how to link these files 

using relationships in MS Access. 

Outcome: This case study will give students practical experience in creating and 

managing databases, designing queries and reports, and understanding the programming 

environment in MS Access. 

 

4.13 References and Suggested Readings  
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UNIT – V 

POWER POINT 

 

UNIT V -    POWER POINT 

Power point: Introduction to Power point - Features – Understanding slide 

typecasting &viewing slides – creating slide shows. Applying special object 

– including objects & pictures – Slide transition–Animation effects, audio 

inclusion, timers.  

Section Topic Page No. 

UNIT - V 

Unit Objectives  

5.1 Introduction 130 

5.1.1 Starting PowerPoint 131 

5.1.2 Saving A Presentation 132 

5.1.3 Basic Elements of A PowerPoint Window 134 

5.2 Features of PowerPoint Presentation 136 

5.3 Understanding Slide Typecasting  137 

5.3.1 Slide Typecasting 137 

5.3.2 Viewing Slides 139 

5.4 Creating Slideshow Applying Special Object 143 

5.4.1 Creating Slideshows 143 

5.4.2 Applying Special Objects 143 

5.5 Include Objects and Pictures  145 

5.6 Slide Transitions 146 

5.6.1 Adding Slide Transitions 146 

5.7 Animation Effects 149 
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5.1 INTRODUCTION 

 

MS PowerPoint is a comprehensive presentation package used for the creation of 

attractive presentations. A presentation can be defined as great visuals, making it easy to 

communicate your ideas and market products effectively. It has everything needed to 

design a professional looking presentation. PowerPoint supports word processing; add 

drawings, graphs and multimedia to presentation. It also consists of tools to manage the 

designing of presentation. The objectives of all these features of the MS PowerPoint are to 

design impressive presentation in short time and little efforts. 

5.7.1 Animation In PowerPoint 149 

5.7.2 Types of Animation 150 

5.7.3 Effect Options 153 

5.7.4 Animation Pane 155 

5.8 Audio Inclusion 158 

5.9 Timers 160 

5.10 Unit- Summary 161 

5.11 Glossary 162 

5.12 Self- Assessment Questions 162 

5.13 Activities / Exercises / Case Studies 162 

5.14 References  and Suggested Readings 163 

UNIT OBJECTIVES 

 This unit aims to provide a various features and functionalities available in 

PowerPoint, including tools for creating presentations, formatting slides, and 

adding multimedia elements.  

 Learners the skills to create engaging and informative slide shows by arranging 

and designing slides, incorporating text, images, and multimedia elements 

effectively. 
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A PowerPoint presentation is made up of a series of slides, which contain the 

information you want to communicate with the audience. This information can include text, 

pictures, charts, video, sound, and more. This class covers the essentials of using 

PowerPoint, including getting started, adding slides, adding text and pictures to slides, 

changing the look of your presentation, and presenting, saving, and printing your 

PowerPoint slideshow. 

5.1.1 STARTING POWERPOINT 

Step 1: Go to the program section in the windows start menu. 

Step 2: Go to MS Office & click on it. A drop-down list is seen 

Step 3: Click on MS PowerPoint & MS PowerPoint window will pop up. 

 
 

 
Step 4: Click on the Microsoft button on the top left. 
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Step 5: Click on new, a new Presentation window will pop up. 

 

Step 6: Click on Create & a new presentation will be created. 

5.1.2 SAVING A PRESENTATION 

Step 1: Click on the Microsoft icon 

Step 2: Click on the Save button 
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Step 3: A new Window for Save As will pop up.  

 

Step 4: Select the drive (by clicking on it: Example: Local Drive (D)) in which you want to 

save the presentation. Then your drive will open up, select the folder in which you want to 
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save the presentation (Example: img folder here) & then give the required name to your 

presentation (Example: MyPresentation here). Your presentation is created & saved with 

the provided name. 

5.1.3 BASIC ELEMENTS OF A POWERPOINT WINDOW 

 Title Bar: This shows the name/title given by you to the current presentation. If 

users do not save the presentation by any name, default name given by MS 

PowerPoint appears in this bar. 

 Menu Bar: Contains menu items like insert, views, design, animations, etc. 

 Office Button: MS Office button on the left-most top. 

 Formatting Toolbar: Have tools like Bold, Italic, Underline, Font shape & size etc. 

to format your data. 

 Zoom Slider: To zoom in or zoom out your presentation. 

 Slide Sorter Pane: This allows us to choose which slides will be shown in which 

sequence during the slide show. 

 Notes Pane: This allows us to type notes that we may require later when preparing 

for the presentation, but they will not be displayed during the slide show. 

 View Buttons: Provides different views of your presentation like : normal, slide 

show & slide sorter. 

 Slide Pane: This is where we type, format, and otherwise designs the slide. 
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Let’s Sum Up 

PowerPoint is a widely-used software application developed by Microsoft, designed 

primarily for creating presentations. It allows users to combine text, graphics, animations, 

and multimedia elements to communicate ideas effectively. With its intuitive interface and 

robust features, PowerPoint has become indispensable in business, education, and 

various other fields for delivering compelling and visually engaging presentations. 

Check Your Progress 

1. What is the primary purpose of Microsoft PowerPoint? 

A) To create spreadsheets 

B) To develop websites 

C) To create presentations 

D) To edit photos 

Answer: C) To create presentations 

2. Which of the following is a common view in PowerPoint? 

A) Print Layout 

B) Slide Sorter 

C) Web Layout 

D) Draft 

Answer: B) Slide Sorter 
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3. What is the default file extension for PowerPoint presentations created in recent 

versions of PowerPoint? 

A) .ppt 

B) .pptx 

C) .pps 

D) .pdf 

Answer: B) .pptx 

4. In PowerPoint, what is a "slide master" used for? 

A) To create a new presentation 

B) To manage background music 

C) To apply uniform formatting to all slides 

D) To add animations 

Answer: C) To apply uniform formatting to all slides 

5. Which of the following elements can be included on a PowerPoint slide? 

A) Text 

B) Images 

C) Videos 

D) All of the above 

Answer: D) All of the above 

 

5.2 FEATURES OF POWERPOINT PRESENTATION 

PowerPoint provides a number of features and customisable options to enhance the 

visual appeal and performance of presentations. Some of these are as follows: 

1. Slide Creation: 

PowerPoint helps create slides that act as individual pages that contain pictures, 

texts, tables, charts, graphics, etc. attached to our presentations. This helps users create a 

meaningful and systematic presentation for our work. 

2. Templates and Themes: 

PowerPoint contains pre-designed templates and themes that can be used to 

enhance the visual appeal of your presentation. PowerPoint offers a number of themes 
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and templates. These well-created themes and templates improve the slides’ and 

presentation’s attractiveness and give them a professional look. 

3. Transitions and Animations: 

PPT helps in creation of visual effects between presentations by using animations 

and transitions. These transitions can be simple or elaborate and can engage the 

audience and create smooth transitions between slides. 

4. Multimedia Integration: 

PowerPoint can help the users to insert images videos audio and animations in the 

slides to create an engaging and dynamic presentation. 

5. Collaboration and Sharing: 

PowerPoint offers collaboration features that allow multiple users to work on a 

presentation simultaneously. Power Point presentations with others through email, cloud 

storage, or collaboration platforms, making it easy to collaborate and distribute work. 

6. Speaker Notes: 

Speaker notes can be added by presenters for use as a reference during the 

presentation. These notes can be hidden from the audience and can be utilised by the 

users to give reminders additional details or signals while giving the presentation. 

Let’s Sum Up 

PowerPoint is a widely used presentation software offering a range of features that 

facilitate creating, editing, and delivering dynamic presentations. Its capabilities include 

slide customization with text, graphics, and multimedia, seamless integration of animations 

and transitions, and tools for collaboration and audience engagement, making it a versatile 

tool for professional and educational settings alike. 

5.3 UNDERSTANDING SLIDE TYPECASTING  

5.3.1 SLIDE TYPECASTING 

Slide Typecasting refers to the process of categorizing slides based on their layout, 

content, and purpose within a presentation. PowerPoint offers several predefined slide 

layouts and types, each designed for specific content and presentation needs: 
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1. Title Slide: 

To create a title slide, go to the "Home" tab, click on "New Slide," and choose a 

layout that features a title placeholder. Customize the title and subtitle as needed. To view 

a title slide, simply navigate to it within the presentation or start the slideshow from the 

beginning. 

2. Content Slide: 

Content slides typically feature text and possibly other media such as images or 

charts. To create a content slide, select a layout with content placeholders or insert text 

boxes and other elements manually. To view content slides, navigate through the 

presentation or start the slideshow. 

3. Bullet Point Slide: 

Bullet point slides are commonly used for listing key points or ideas. Create them by 

selecting a layout with bullet point placeholders or by manually adding bullet points to a 

text box. To view bullet point slides, advance through the presentation or start the 

slideshow. 

4. Image Slide: 

Image slides showcase visuals such as photos, diagrams, or illustrations. To create 

an image slide, insert an image onto a slide layout. To view image slides, navigate through 

the presentation or start the slideshow. 

5. Chart/Graph Slide: 

These slides display data using charts or graphs. Create them by inserting a chart 

or graph onto a slide layout and entering your data. To view chart/graph slides, navigate 

through the presentation or start the slideshow. 

6. Transition Slide: 

Transition slides help transition between different sections or topics within the 

presentation. To create a transition slide, insert a slide with transition effects or animations. 

To view transition slides, move through the presentation or start the slideshow. 
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7. Conclusion Slide: 

Conclusion slides summarize key points or takeaways. To create a conclusion slide, 

design it to encapsulate the main ideas of the presentation. To view the conclusion slide, 

navigate to it within the presentation or start the slideshow. 

Let’s Sum Up 

Slide typecasting in PowerPoint involves assigning specific slide layouts to 

effectively organize and present content. It streamlines the creation process by offering 

predefined templates that structure text, media, and data, ensuring clarity and visual 

coherence throughout presentations. 

5.3.2 VIEWING SLIDES 

The presentation can be view it in different ways. Select the View tab. Locate the 

Presentation Views group. It displays four options to view presentations; Normal View, 

Slide Sorter View, Slide Show View and Notes Page View. 

Normal View: The normal view appears by default when we open the PowerPoint window. 

We create and edit slides in Normal View. This view also offers three view options out of 

four options in the form of buttons on the status bar. 

 

https://www.studocu.com/in?utm_campaign=shared-document&utm_source=studocu-document&utm_medium=social_sharing&utm_content=oa-unit-v
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Slide Sorter View: It offers miniature or thumbnail version of all slides. You can see all 

your slides at one time in the screen. You can also drag or delete the slides to rearrange 

them.  
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Slide Show View: It displays your presentation in full screen mode. It also offers an 

additional menu at the left bottom corner of the slide. 

 

 

Notes Page View: This view provides space below the slide to add notes. 
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Let’s Sum Up 

In PowerPoint, there are primarily two types of slide views: the Normal view, which 

allows for editing and organizing slides with a sidebar for easy navigation, and the Slide 

Show view, which displays slides full screen for presentations, offering real-time previews 

of animations and transitions. These views cater to both creation and delivery phases of 

presenting, ensuring seamless preparation and effective communication of ideas. 

Check Your Progress 

1. Which mode allows you to view your presentation in full-screen format during a 

slideshow? 

A) Normal View 

B) Slide Sorter View 

C) Reading View 

D) Slide Show View 

Answer: D) Slide Show View 

2. What key can you press to start the slideshow from the beginning? 

A) F5 

B) F2 

C) Ctrl + P 

D) Esc 

Answer: A) F5 

3. During a slideshow, how can you move to the next slide? 

A) Press the Spacebar 

B) Click the mouse 

C) Use the arrow keys 

D) All of the above 

Answer: D) All of the above 

4. Which feature allows you to jump to a specific slide during a presentation? 

A) Slide Master 

B) Slide Navigation Pane 

C) Hyperlink 

D) Notes Page 

Answer: C) Hyperlink 
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5. What does the "Esc" key do during a slideshow? 

A) Pauses the presentation 

B) Ends the slideshow 

C) Restarts the slideshow 

D) Goes to the previous slide 

Answer: B) Ends the slideshow 

 

5.4 CREATING SLIDESHOW APPLYING SPECIAL OBJECT 

5.4.1 CREATING SLIDESHOWS 

You can start presenting your slideshow in a number of ways: 

1. Go to Slide Show tab →Start Slide Show group → From Beginning or From Current 

Slide command. 

2. Select the Slide Show icon from the status bar at the bottom of the screen. 

3. PresstheF5 key on the keyboard. 

Move through your slides by clicking the mouse, pressing the spacebar, or using the arrow 

keys on the keyboard. 

 

 

Exiting Your Slideshow 

To exit your slideshow: 

1. Press the Esc key on the keyboard. 

2. Right-click on the slide and select End Show at the bottom of the resulting menu. 

5.4.2 APPLYING SPECIAL OBJECTS 

Creating a slideshow with special objects in PowerPoint can make your presentation 

more engaging and visually appealing. Here's how you can apply special objects: 

1. Open PowerPoint: Launch PowerPoint and start a new presentation or open an 

existing one. 

2. Insert Special Objects: Click on the "Insert" tab in the top menu bar. Here are 

some special objects you can insert: 

https://www.studocu.com/in?utm_campaign=shared-document&utm_source=studocu-document&utm_medium=social_sharing&utm_content=oa-unit-v
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 SmartArt: Click on "SmartArt" to insert diagrams, processes, cycles, 

hierarchies, matrices, pyramids, or other types of graphics. 

 Charts: Click on "Chart" to insert various types of charts like bar charts, line 

charts, pie charts, etc., to visualize data. 

 Shapes: Click on "Shapes" to insert pre-defined shapes or draw custom 

shapes on your slides. 

 3D Models: Click on "3D Models" to insert 3D objects into your presentation. 

 Icons: Click on "Icons" to insert scalable vector icons and symbols from a 

library of available options. 

 Pictures: Click on "Pictures" to insert images from your computer or online 

sources. 

 

 

 

 

 

3. Customize Special Objects: After inserting a special object, you can customize it 

according to your needs: 

4. Arrange and Format Objects: Arrange the special objects on your slides and 

format them to make them visually appealing and coherent with your overall design. 

Use alignment guides and grids to position objects precisely. 
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5. Preview Your Slideshow: Before presenting, preview your slideshow to ensure 

that all special objects are displayed correctly and that animations and transitions 

work as intended. 

6. Save Your Presentation: Once you're satisfied with your slideshow, save your 

presentation by clicking on the "File" tab and selecting "Save As." 

 

5.5 INCLUDE OBJECTS AND PICTURES  

1. Insert Pictures: 

 Click on the "Insert" tab in the top menu. 

 Click on "Pictures" in the Images group. 

 Choose a picture from your computer, or select "Online Pictures" to search 

for images on the web. 
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 Select the picture you want to insert and click "Insert." 

2. Insert Objects: 

 Depending on the type of object you want to insert, you can use various options: 

 Shapes: Click on "Shapes" in the Illustrations group under the "Insert" tab. Choose 

a shape from the gallery, click and drag on your slide to draw the shape. 

 Icons: Click on "Icons" in the Illustrations group under the "Insert" tab. A panel will 

open on the right side with a library of icons. Select an icon and click "Insert." 

 3D Models: Click on "3D Models" in the Images group under the "Insert" tab. 

Choose whether to insert from a file, online source, or stock models provided by 

Microsoft. 

 SmartArt: Click on "SmartArt" in the Illustrations group under the "Insert" tab. 

Choose a SmartArt graphic from the gallery and click OK to insert it into your slide. 

Let’s Sum Up 

PowerPoint is a versatile presentation software that enables users to create 

dynamic slideshows incorporating text, images, videos, and objects like charts and 

diagrams. Its intuitive interface and extensive editing tools make it a popular choice for 

organizing information visually and delivering engaging presentations efficiently. 

5.6 SLIDE TRANSITIONS 

 

5.6.1 ADDING SLIDE TRANSITIONS 

Transitions between slides cover much more than some movement between one 

slide and the next. Slide transitions in PowerPoint many options including timings and 

sounds. In either the Slide Sorter or Normal view, select the slide or slides to which you 

want to apply the transition to. Now, let’s do it practically. 
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Step 1: From the Menu ribbon, select the Transitions tab. 

 

 

Step 2: The most commonly used animations will appear in the center. To preview more 

transition options, click the down arrow. 

 
Step 3: Select a transition from the list. Clicking it will apply the transition to the slide. You 

can also select Apply to All to apply the same transition to all your slides. 

Step 4: In the Duration option, enter the speed at which you want the transition to play. 
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Step 5: In the Sound field, use the drop-down menu to select a sound to play during a slide 

transition, if desired. 

 

 

Step 6: Indicate how you want the slide transition to occur by selecting an option under 

the Advance Slide heading. Select On mouse Click if you want the transition to take place 

when you click the left mouse button. 

Select Automatically After if you want the transition to occur after a specified time. Use the 

up and down arrow keys in the blank box to specify the number of seconds which should 

pass before the transition takes place. 
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Let’s Sum Up 

PowerPoint slide transitions are animations that occur when moving from one slide 

to the next, adding a dynamic element to presentations. These transitions can be 

customized in terms of style, speed, and sound to enhance the audience's viewing 

experience. 

 

5.7 ANIMATION EFFECTS 

PowerPoint animations are used to create games or movies. But majorly it is used 

for the purpose of education and business sectors. You can see this option under the 

Animations tab. Now we will learn more about animations in MS PowerPoint. 

 

 

5.7.1 ANIMATION IN POWERPOINT 

Animations are one of the most important features of MS PowerPoint from which we 

can make creative templates out of it. Now we see the various options present under the 

animations tab and discuss them one by one: 

 Preview 

 Type of animation 

 Effect options 
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 Add Animation 

 Animation Pane 

 Trigger (available for new version) 

 Animation Painter (available for new version) 

 

 

 

5.7.2 TYPES OF ANIMATION 

There are so many in-built animation effects provided by MS PowerPoint, and they 

are categorized into four types: 

 Entrance: It has animations telling that how an object should enter. For example, 

with the fly animation, the object will “fly” onto the slide from any of the 4 directions. 

 Emphasis: This type of animation usually occurs by the mouse clicks i.e when the 

object is already on the slide. For example, we can make the object wave after the 

entrance animation has finished. 

 Exit: These have a set of animations to control the exit animations. For example, in 

the Fade animation, the object will fade away. 

 Motion Paths: They are similar to emphasis animation effects, but these 

animations are a little advanced as the object will move in a specified path. These 

paths can be edited also. 
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Steps to apply the animation: 

Step 1: Select the object you want to animate. 

Step 2: Go to the animation tab and click on the dropdown to view all types of animations. 

Step 3: A drop-down menu of animation effects will appear. Select the desired effect. 

Step 4: The effect will apply to the object. In the Slide pane, a star symbol appears next to 

the slide, by which we can confirm that animation is applied. 

 

 

 

 

 

 

 

 

 

 

Preview 

Animation effects that you have applied will show when you play the slide show. 

You can preview the animations quickly for the current slide without clicking the option of 

the slideshow. 
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Steps to preview: 

1. Navigate to the slide you want to preview. 

2. From the Animations tab, click the Preview command. The animations for the current 

slide will play. 

 

5.7.3 EFFECT OPTIONS 

Some effects will have options you can change. For example, in the effect of the 

random bars, we can control that we need vertical or horizontal bars. We can use these 

options by accessing the Effect Options command in the Animation group. It totally 

depends on the animation which is selected. 
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Add Animation 

If you want to add new animation then we can reselect in the animation group but to 

add new animation without changing the existing one we use this option. And sometimes 

to make the content interactive we need to add 2 or more effects. To apply these changes 

click on Add Animation command, this option will allow adding new animations without 

changing the old ones. 

 

Steps to apply multiple animations to a single object: 

Step 1: Select an object. 

Step 2: Click the Animations tab. 

Step 3: In the Advanced Animation group, we need to click the Add Animation command 

to view the available animations. 

Step 4: Select the desired animation effect. 
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Step 5: If the object has multiple effects then for every effect it will show numbers 

according to the priority i.e., numbers indicate the order in which the effects will occur. 

 

5.7.4 ANIMATION PANE 

The Animation Pane option has the power to manage the timing of particular 

animations. You can easily modify the effects related to the animations like reordering the 

animations according to the preference and time interval. 

Steps for Operating Animation pane: 

Step 1: Open the Animations tab, on the right side click on the animation pane option. 

Step 2: A separate dialogue box gets opened on the right side of the window. It shows all 

the effects for the current slide in which they will appear. 

Step 3: We can also set the start time, delay time, and also we can set when to move to 

the next slide, for this, we have 3 options: 

 Start on Click 

 Start with Previous 
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 Start after Previous 

 
 

 

 

 

 

 

 

 

 

 

Step 4: We can reorder animations with the help of two options which are a) Move 

Earlier b) Move Later 

Note: We can also reorder the animations according to our requirement, for that we just 

need to click and drag. 
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Let’s Sum Up 

PowerPoint's animation effects enhance presentations by adding movement and 

visual interest to text, images, and other elements, making them more engaging and 

easier to follow. These effects range from simple transitions like fades and wipes to more 

complex animations that can be customized to suit the presenter's needs. 

Check Your Progress 

1. Which tab in PowerPoint contains the options for adding slide transitions?  

A) Home 

B) Insert 

C) Transitions 

D) Animations 

Answer: C) Transitions 

2. What is the default duration for most slide transitions in PowerPoint?  

A) 0.5 seconds 

B) 1 second 

C) 2 seconds 

D) 3 seconds 

Answer: B) 1 second 

3. Which of the following statements is true about animations in PowerPoint?  

A) Animations can only be applied to entire slides. 

B) Animations can be applied to individual objects on a slide. 

C) Animations can only be used in the first slide of a presentation. 

D) Animations cannot be customized. 

Answer: B) Animations can be applied to individual objects on a slide. 

4. What is the purpose of the "Effect Options" button in the Animations tab?  

A) To change the color of the slide background 

B) To customize the direction or sequence of the animation 

C) To delete all animations from the presentation 

D) To preview the slide without animations 

Answer: B) To customize the direction or sequence of the animation 
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5. Which of the following is NOT a type of slide transition in PowerPoint?  

A) Fade 

B) Wipe 

C) Zoom 

D) Expand 

Answer: D) Expand 

 

5.8 AUDIO INCLUSION 

Inserting Audio in Presentations 

MS PowerPoint allows its users to add audio files and recordings to presentations 

to give a better look and feel to your slides. 

Steps for Adding Audio: 

There are some steps for inserting audio in the MS PowerPoint: 

Step 1: Under the Insert tab, so many options are available where we can choose what 

feature we want to insert in their presentation. This may include images, audio, video, 

header, footer, symbols, shapes, etc. 
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Step 2: On the Insert tab, within the Media group click the Audio. 

 

 

There are two ways of adding audio in the presentation: 

(i) Audio on my PC   

(ii) Record Audio  

Step 4: Click on the Record Audio button: 

 

Step 5: Click on the “Square Blue” button to stop recording it. 

 

For Playing the audio, click on the green-colored “Play” button. 
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Let’s Sum Up 

Including audio in PowerPoint presentations enhances engagement and 

understanding by providing auditory explanations and context to the visual content. This 

multimedia approach can cater to diverse learning styles, making the presentation more 

dynamic and effective. 

5.9 TIMERS 

Adding timers in PowerPoint can be a useful tool for managing time during 

presentations, quizzes, or interactive sessions. Here’s a step-by-step guide on how to add 

timers in PowerPoint: 

1. Open Your Presentation: 

 Open the PowerPoint presentation where you want to add a timer. 

2. Insert a Shape or Text Box: 

 Go to the Insert tab. 

 Choose Shapes or Text Box and create a box where the timer will be 

displayed. 

3. Set Up the Timer: 

 Click inside the shape or text box and type the starting time (e.g., "10" for a 

10-second timer). 

4. Add Animations: 

 Select the shape or text box. 

 Go to the Animations tab. 

 Select Add Animation>Disappear (or any exit effect). 
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5. Configure the Animation Timing: 

 With the shape or text box still selected, click on the Animations Pane. 

 In the Animations Pane, right-click on the animation and select Timing. 

 Set the Duration to 1 second and the Start to After Previous. 

6. Create Countdown Steps: 

 Duplicate the shape or text box for each second of the countdown (e.g., from 

"10" to "1"). 

 Adjust the text in each box accordingly. 

 Set the Start of each subsequent shape or text box to After Previous. 

7. Preview the Timer: 

 Click Slide Show>From Current Slide to test the timer. 

 

Let’s Sum Up 

A timer in PowerPoint can be used to manage the duration of slides or 

presentations, ensuring that each segment adheres to a specific time frame. This feature 

is particularly useful for timed presentations, allowing presenters to maintain a consistent 

pace and avoid overrunning their allotted time. 

5.10 Unit Summary  

 It provides a comprehensive introduction to PowerPoint, focusing on its features and 

functionalities for creating dynamic and engaging presentations.  

 To understand the different types of slides and how to navigate through presentations 

effectively.   
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 The unit also covers slide transitions, animation effects, audio inclusion, and timers, 

empowering learners to create captivating and professional presentations that 

effectively convey their message. 

5.11 Glossary 

 Slide  -  A single page or screen in a PowerPoint presentation. 

 Animation  - Visual effects applied to objects on a slide. 

 Transition  - Effects that occur when moving from one slide to the next. 

 Template  -  Pre-designed layout and design for slides. 

 Master Slide  - A slide that stores information about the theme and slide layouts. 

 Slide Show  - A sequence of slides displayed in order during a presentation. 

5.12 Self-Assessment Questions 

1 Explain the process of creating a slide show in PowerPoint. What steps do you 

need to take to add slides and organize their sequence? 

2 How can you insert objects and pictures into a PowerPoint slide? Provide two 

methods for inserting objects or pictures. 

3 Describe the purpose of slide transitions in PowerPoint. Give an example of a 

slide transition effect and when it might be used. 

4 What are animation effects in PowerPoint? How can you apply animation to 

objects on a slide? 

5 How can you include audio in a PowerPoint presentation? Describe the steps 

to add audio files to your slides. 

6 What is the purpose of timers in PowerPoint? How can you use timers to 

control the timing of slide transitions or animations? 

 

5.13 Activity 

Activity 1: Introduction to PowerPoint Features 

1. Objective: To get familiar with the basic features of PowerPoint. 

2. Activity: 

o Task: Create a 5-slide presentation about any topic of your choice (e.g., 

"Benefits of Healthy Eating"). 
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o Instructions: 

 Use at least three different slide layouts (e.g., title slide, content slide, 

picture with caption). 

 Include a title slide and a conclusion slide. 

 Add a background color or image to each slide. 

3. Outcome: Understanding of basic slide creation, layouts, and visual customization. 

Activity 2: Slide Typecasting & Viewing Slides 

1. Objective: To understand different slide types and viewing modes. 

2. Activity: 

o Task: Create a 7-slide presentation on the topic "Environmental 

Conservation". 

o Instructions: 

 Use at least four different types of slides (title slide, comparison slide, 

content with image, chart slide). 

 Switch between Normal, Slide Sorter, and Reading views to ensure 

content and formatting consistency. 

 Use the "Notes" section to add speaker notes for each slide. 

3. Outcome: Understanding the application of various slide types and viewing modes. 
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